XCODE Debugger doesn't break on included "cpp" files?


#1

Does the XCODE Debugger doesn't break on included "cpp" files, when you set breakpoints?

Or is this just me? And if yes, it there a workaround.


#2

There's a config you can set to force it to work properly.. I'm sure there's a thread about this somewhere on the forum, but can't seem to find it..


#3

if anybody finds it, that would be great to know for all juce users ;)

 


#4

Is there an option to disable all "cpp" including of juce files, instead compiling directily in the project, in introjucer 

If found some other obsucrish clang debugger behavior, and its impossible to find the problem in my project :((

It seems the programm counter jumps out of a method without any logic, when debugging step by step. but when placing jassertfalse it, it does break :((

 


#5

I used this link and it works flawlessly.

 

 

http://stackoverflow.com/questions/17680401/xcode-doesnt-break-in-included-cpp-files/17693317#17693317


#6

According to LLDB's FAQ (http://lldb.llvm.org/troubleshooting.html)

Execute the following command in the terminal:

echo "settings set target.inline-breakpoint-strategy always" >> ~/.lldbinit

and then restart the XCode