ASIO setup for using in plugin host


#1

Hi, I was going through one of the basic tutorials, and I was trying to do the hello world vst plugin tutorial. I noticed in the host runner that the asio driver was not a choice in the drop down. So I got the steinberg sdk and enabled it in the projucer, and also pointed everything to the necessary header files in the asio sdk. OK, great.......so I did a build and everything was succesful, but when I run the host runner again, the asio is still not an option in the drop down list. I thought I set everything up correctly so I don't know why I can't get it to recognize that I am using asio. Also, on a side note.....the midi in patch chord from the midi in to the midi out is red. I am not sure if that is anything to worry about, perhaps that is a different issue, I would think that if it is read that means it isn't recognizing my midi input. Any help would be great, I used the forum to get as far as I got, but then got stuck, when I got a successful build but the asio still doesn't show up in the drop down.

Thanks.


#2

Well do you have an ASIO compatible sound card? If not you will not be able to select the ASIO device. You can also download Asio4all to get "emulated" ASIO support for any windows compatible sound card.


#3

Is it the driver or the soundcard?  When I launch Ableton live, and see the settings, it gives a choice to select Asio for driver type, that is showing up in the Ableton live software dropdown. Then I select my audio interface which is the Boss GT-001. Now when I launch the Plugin host to test my plugin, the dropdown list that isn't snowing, "Asio" as a choice, is that refering to the soundcard type, or the driver type. Because in the other dropdown list, it does give me the choice to choose the Boss GT-001, so that is showing up fine.


#4

Hi all, ASIO is now showing as a choice of one of my sound drivers in the drop down list. Here is what I did to fix it. I had to rebuild the plug in host. When I rebuilt it, I enabled ASIO as one of the types, and pointed the header and libraries to point to the ASIO sdk location. Once I rebuilt the plug in host, the ASIO now shows up in the Plug in host drop down. 

It is now working.

 


#5

I have the same problem.  how did you add the ASIO path to the Projucer?  I am just getting started with Juce (and C++.)

 

Vst and Vst3 paths seemed to appear like magic when I installed them to C\:SDKs. 

But ASIO is not being magical.  I put it in that same folder.  I don't see a way to add a path to the list in global options.

<edit>

I found the switch in juce_audio_devices, and turned it on.  Now it breaks on build.

I am doing an x64 build in VS 2015.

 

But when I look in ASIOAudioDevice class it looks to be inside the file juce_Win32_ASIO.  Don't know if that matters I will poke around more.

 

<edit>

I tried adding c:\SDKs\ASIOSDK2.3\common and c:\SDKs\ASIOSDK2.3 to both the user header paths and the system header paths, but VS still says:

1>c:\juce\modules\juce_audio_devices\juce_audio_devices.cpp(83): fatal error C1083: Cannot open include file: 'iasiodrv.h': No such file or directory


So I guess that's not where I need to put that path?


#6

Okay, sorry, I think my response is in the wrong subforum.  Problem with starting with a search rather than just asking a question.

 

I'm trying to build the HOST example.

 

I went to the Projucer intro tutorial to see what I might have missed, and I've run into another problem.  According to the tutorial there should be an architecture tab in a VS2015 build settings page, but my Projucer does not have it.   Thoughts?


#7

Went to fullscreen mode, and viola!  More build options.

 

One problem solved.  The default grey for scrollbars does not show up well on my monitor.  That goes for webpages, and OS windows as well.  

 

In fact, the whole Disappearing Scrollbar UI esthetic that is sweeping the nation is seriously bumming me out.   At least Juce's become visible when you hover.  Win10's aren't visible until you start to move them, by which time, who cares?  I'm no longer looking over there.

 


#8

Okay I reread above:

 

"When I rebuilt it, I enabled ASIO as one of the types, and pointed the header and libraries to point to the ASIO sdk location"

 

Header AND libraries.  Okay.  Needed to use the subfolder \common, too.  I guess it makes sense that paths do not search sub-folders.

 

Fun, I have the host demo working in x64.  Mark this closed, sorry to babble in public.  But may help another noob.