Asking for help with an Xcode linker issue


#1

Hi all,

During my holiday on a Greek island (nice!) I am for the first time trying to build a plugin on OSX, which I worked on in Windows. I am quite new to OSX and Xcode, so of course I am running into all kinds of issues (also the AU resource stuff of course!).

I finally have all the source code files compiling OK and am now left with a linker problem.

I hope someone can kindly tell me what I should try or do.

I use the Intel Performance Primitives 8.x, which are installed in /opt/intel/composer_xe_2013_sp1.0.074 by default.

The compiler finds the header files, for which I set the path in the .jucer file.

However, the linker stops and tells me it cannot find the two .a files that I need to link, which are specified in the .jucer file.

I set the path in the .jucer file (as I have for the Windows setup) - I also tried to add it in Xcode to the linker settings, but nothing helps.

The path is /opt/intel/composer_xe_2013_sp1.0.074/ipp/lib

Do I need to chmod something on the two .a library files?

Does the linker mangle the path internally to something else? Should I relocate the Intel IPP files to another location?

Thanks in advance for any tips!

Peter


#2

I have had a similar problem including the Dirac library on iOS - strangely enough it works on osx but not ios, even though it is set correctly in Introjucer.

Under Targets->General, the Library search paths got mangled somehow because of a space in the path.
I fix it by manually adding the library under Target->Build Phases->Link Binary With Libraries.

I'm not sure if that is the same issue, but it sounds familiar.