AU Plugin won't generate sound?


#1

First of all, greetings, everyone.

I've tried to make my own crossplatform plugin, and honestly, I'm at the verge of giving up. One reason is because of a strange problem with the Mac AU build (the format I normally use for other plugins): it will not generate any sound output.

Unfortunately, I don't think it's as simple as modifying my own source code anymore, because when compiling that same code as a VST with Visual Studio 2010 in VMWare, the result DOES generate sound properly in Windows!

What am I doing wrong? I've compiled using both the 10.9 SDK and the 10.11 SDK, and I'm using Juce 4.0.2. My system is also a late 2013 Mac Pro, if that helps.


#2

Sadly it's unlikely that anyone reading this will be psychic enough to tell you what you've done wrong based on just saying "there's no sound"!


#3

Then by all means, tell me what else I should provide. I've already said that it appears the problem may not be the source code of my plugin, as it compiles correctly as a Windows VST, and if I'm right that it's not my source code, that narrows it down to either the config settings in Projucer (which I've already checked through but I'm willing to try to provide anyway), or the AU framework version that was provided with JUCE.


#4

Surely it's obvious what's going wrong when you debug it?

(You have tried debugging your code before asking for help, right..?)


#5

It could still be the source code...

  • What happens when building a VST on Mac?
  • Are you building/testing 32 or 64 bit builds?
  • Have you tried for the sake of sanity replacing the DSP with something really obvious? (maybe output silence, white noise, or turn it into a basic gain plugin)
  • Have you checked that what you are testing is definately what you just built? (check both /Library/Audio/Plugins/Components and ~/Library/Audio/Plugins/Components, the user library overrides the shared one if I remeber correctly, also I reccomend making sure you quit and re-open the host after rebuilding) 
  • Are you testing debug or release configurations?
  • Have you tested in multiple hosts?

They are just some questions off the top of my head. As Jules says stepping through with a debugger should reveal any problems.