Audio unit + plugin host problems


#1

I’m playing around with the Plugin Host example and changed the plugin search directories from whatever the default was. Now all of my Apple supplied audio units are gone and I’m not sure where to point juce at to find them. The aren’t in the standard places that you put 3rd party components and the few 3rd party AUs I’ve tried don’t work correctly in the host. Does anyone know how to get the apple audio units to show up again?

I just want to get DSLMusicDevice back because that one actually worked :slight_smile:

Also… any idea why AU hosting is so buggy? A lot of plugins show up with no audio out (just midi in) or straight up crash when I use them. Work fine in AU Lab.


#2

I just rewrote a lot of the AU loading code to handle those Apple units, but because they don’t actually exist as files, there’s a bit of bodging involved. I’m not sure how you’d have got rid of them from the list though - it’s supposed to find them regardless of what path you’ve entered…


#3

Hmm, maybe it was because I rolled back to 1.46. I was using latest SVN but synced up and couldn’t build on mac so I decided to switch back to the last official release.


#4

Yes, I only just added support for the apple units.