Invalid Audio Unit


#1

So I checked out the latest JUCE from GIT. Open the JuceDemoPlugin project and only enable the AU in JucePluginCharacteristics.h. It builds a JuceDemoPlugin.component without problem. Then I copied it into /Library/Audio/Plug-in/Component, but no host can find/verify this plug-in. The hosts I tried are: Logic 9, AULab, auval and JUCE Plugin Host.

Any ideas? Thanks.

I’m on 10.6.2


#2

I found out. My internal framework should have a install path starting with @loader_path instead of @executable_path