AudioPlugin Host & plugin detection

Hello :slight_smile:

I looked for an answer about my problem but was unable to find something approaching.

I would like to create audio plugins with Juce and, in order to do that, I tried if I would be able to test them in the AudioPlugin Host by using the ArpeggiatorTutorial example provided in tutorials.

I first tried on a MacOS computer, and it found with no problem my plugins once I added the file where they were. I was then able to add them in my PluginHost and try the ArpeggiatorTutorial inside.

Then, I moved on Windows and tried the same manipulation (in order to start coding my audio plugins on Windows), but even thought I’ve been trying since 3 days, I’m unable to make the AudioPlugin Host find my plugins, despite the fact I’ve been doing the same as I did on MacOs.

It seems that, on MacOs, the .AU is enough to get the AudioPlugin Host detecting the plugin, but on Windows it seems not to find anything… I tried to move the plugins to test, I tried numbers of manipulations on compilation, on file paths, nothing seems to work…

Could anybody bring me some solution or any new ideas?
Thank you :slight_smile:

AU is a macOS only format. Windows supports VST and VST3

Rail

Also the CPU bit architecture must match, 32 bit host for 32 bit plugins, 64 bit host for 64 bit plugins. (So called “bit bridging” is possible to do, but the Juce plugin host doesn’t have that implemented.)

In your Plugin project in the Projucer exporter, make sure you have the “Copy Step” enabled, so the plugin will end up at the right location.
It makes it a bit trickier, that this is configurable, and some hosts were seen, that look in non-default locations (IIRC Fruity Loops)

Yeah, I know, I was wondering why on MacOS, the AudioPlugin Host seemed to find the VST plugin while Windows didn’t, if it has something to do in any kind if the absence of .AU on Windows or not

Is that any way to know what kind of plugin I am making/using so I can check if it matches my CPU ? (weaher it is a plugin I found in tutorials or one I coded myself)

Thank you very much for your answer, I checked this parameter (it was disabled) and enabled it but it unfortunately didn’t seem to change anything :confused:

Did you check, if any file ends up at the path configured right below the copy step select?

The %CommonProgramW6432% is an environment variable of your system, you can copy that into the file explorer location bar and it will show you the folder…

The architecture for your plugin is just a few lines below. Have a read through that page, they are all useful settings.

To make them work, you need to save the project with Projucer and reload your VS solution before building (if it doesn’t work as expected, I had to close VS before saving in Projucer and open fresh, but that could have been an old VS or I did something wrong).

Is your plugin project set up to build VST2 and/or VST3? Maybe on Windows it is just building the shared code and standalone application version of the plugin.

Note that after changing all these settings in Projucer, you have to re-export the Visual Studio project and rebuild there.

Thank you very much for all your answers and ideas. I tried them all but didn’t find where the problem could come from…
Lacking of time at the moment, I have to go back on Mac because I can’t stay stuck on this for too long, but if someone has got the answer it may help someone with the same problem in the future ^^