AUs in XCode 5


#1

Hi there,

Brand new to JUCE, and I'm trying everything out to get a feel for the library. I've been having some difficulties getting the "audio plugin demo" to compile under XCode 5—though after reading through the forum posts, it sounds like this is a common thing as Apple keeps mucking with things.

My biggest issues seems to be that the files in the project listed in the "Juce AU Wrapper" group are missing...  and I cannot locate them. However, I believe these files are all a part of the Core Audio Utility Classes, which I've downloaded and included in the project as a replacement. It seems like the build almost completes, but then I get an error when resources are tried to be added:

/Library/Developer/CoreAudio/AudioUnits/AUPublic/AUBase/AUResources.r:74: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Undefined variable (RES_ID) not allowed in expression.
/Library/Developer/CoreAudio/AudioUnits/AUPublic/AUBase/AUResources.r:74: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Expected number, but got ','
/Library/Developer/CoreAudio/AudioUnits/AUPublic/AUBase/AUResources.r:78: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Undefined variable (RES_ID) not allowed in expression.
/Library/Developer/CoreAudio/AudioUnits/AUPublic/AUBase/AUResources.r:78: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Expected number, but got ','
/Library/Developer/CoreAudio/AudioUnits/AUPublic/AUBase/AUResources.r:82: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Undefined variable (RES_ID) not allowed in expression.
/Library/Developer/CoreAudio/AudioUnits/AUPublic/AUBase/AUResources.r:82: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Expected number, but got ')'
/Library/Developer/CoreAudio/AudioUnits/AUPublic/AUBase/AUResources.r:88: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Undefined variable (RES_ID) not allowed in expression.
/Library/Developer/CoreAudio/AudioUnits/AUPublic/AUBase/AUResources.r:88: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Expected number, but got ','
/Library/Developer/CoreAudio/AudioUnits/AUPublic/AUBase/AUResources.r: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Since errors occurred, /Volumes/HD/Users/adam/Library/Developer/Xcode/DerivedData/JuceDemoPlugin-dgumeirhxmfknoaccpusmyxszpqi/Build/Intermediates/JuceDemoPlugin.build/Debug/JuceDemoPlugin.build/ResourceManagerResources/Objects/AUResources.rsrc's resource fork was not written.
Command /Applications/Xcode.app/Contents/Developer/usr/bin/Rez failed with exit code 2

Has anyone had success getting the demo plugin project to build under XCode 5? If so, would you mind pointing me in the general direction of a helpful post or perhaps write up a small summary of what you had to do in order to get everything to work?

My apologies in advance if there is already such a posting here...  I've looked, but can't seem to find anything that applies to XCode 5.

Thanks,

Adam

 

 


#2

I haven't made the jump to Xcode 5 yet, but there were threads from other people mentioning it, so I think it works. If you get your paths sorted out, it'll probably be just fine.


#3

Thanks, Jules. Still not sure what's up with the RES_ID error...  but I'll look for those threads and play around with this a bit longer. If all else fails, I'll back down to the latest 4.x release of XCode and begin from there.

If I have success I'll post my results and info on what I had to do.

 

Cheers,

Adam


#4

You need to right click on the XCode app and select “Show package contents”…

Then in Contents/Developer add an Extras folder with the CoreAudio SDK

Video:

In XCode 3.x this was kept externally in the Developer folder so you may have it on your hard drive if you had XCode 3.x installed… otherwise get it from Apple.

Rail


#5

I met the same prolems with Xcode 5. I have done according to what I found in forum, downloading CoreAudio and copying to /Applications/Xcode.app/Contents/Developer/Extras and /Library/Developer. However, this doesn't solve the problem.

I noticed that in the video, there is HAL folder in CoreAudio, but I don't have it in my copy. Is it because of this?

I am new to JUCE and stuck now. Is there a soluction now?

Thanks,

Michelle


#6

Hello

 

I'm working on this too, Basicaly we took the coreaudio sdk from the code sample download of feb 2012 (as the coraaudio tools of july 2012 do not include it)

Then I used the approach mentioned to install it in the xcode.app, It worked fine.

It also worked with This folder inside my own source (as long as you change the paths)

 

BUT

The trouble came with the REZ, as I still need to use this to be compatible with Live, and The problem is that I can't find AudioUnit/AudioUnit.r, nor CoreServices/CoreServices.r on my computer, i don't know if this is becasue I'm on 10.9 with only xcode5

 

best


#7

AudioUnit.r is in the VST 2.4 SDK

CoreServices.r is in Developer\Headers\FlatCarbon\ inside the XCode bundle

Rail