Blank property pages for 64-bit projects with VS2013


#1
  • Create a GUI project
  • Use a VS2103 target
  • Set the Debug configuration to x64. 
  • Save and open in VS. 
  • Open project properties
  • Project properties is (unrecoverably) BLANK!!

Tested with recent jucer and Update 5 and 4 of Visual Studio 2013. 

Confirmed on two different systems.  Though it's weird if I compile a really quite old introjucer 3.1 it looks like i'm getting the same beahaviour ... am I doing something dumb and wrong?

Sometimes I have to switch architectures in Visual Studio but whatever happens using an introjucer created project with an x64 specification I end up in a blank set of property pages from which there is no return...

I can't seem to create the behaviour with VS2015.

Maybe it's a Visual Studio 2013 thing I've never notice before, but if I create a 64-bit project from within Visual Studio (rather than using Introjucer) I can't recreate the bug.


#2

Hi,

I just followed your exact steps (using VS2013 Express) and can't reproduce this. The Properties pages look fine. Everything compiles and runs correctly. Fabian says that it's working on his Windows machine as well. Not sure what's going on...

That being said, you should never edit the Properties in VS anyway, rather you should use the Introjucer for all build settings.


#3

That's odd, because I've got two completely different systems here exhibiting the behaviour, and two different update versions of VS2013 Community (4 and 5).  I've tried different versions of Introjucer as well, creating the project from scratch each time.

I only wanted to access the properties because I'm trying to debug a separate underlying issue where the target folder for x64 builds seems to have changed .. !!   


#4

OK, weird, I tried VS 2013 Express Update 4 and the newest tip of the Introjucer... also created a new GUI project from scratch, exactly following your steps.

Maybe something is messed up with your VS? If it helps, I uploaded the project I created here (just a default Introjucer GUI app displaying "Hello World")

https://drive.google.com/file/d/0B-YcSuujrbGNc3RlRzVIVG5yN1E/view?usp=sharing


#5

Cheers Timur - Much appreciated.  I'll get on the case this evening.  Perhaps it's an extension I have on both systems that's causing the problem or something...


#6

Yep, please check if my project is still giving you empty props pages, and then at least we know if it's the Introjucer's fault or your IDE's.


#7

Okay - your project: 

  • Open VS2013.  Works fine. 
  • Open JUCER, re-save.  Works fine.

I think I'm narrowing it down though now...so: 

  • Open your project. 
  • Set the Release Build to be 32-bit 
  • Leave the debug as 64-bit
  • Save and open VS2013
  • Open properties. 
  • Select the 32-bit and/or 64-bit option from the drop down. 
  • The properties vanish unrecoverably.

 

 


#8

Are you setting the build architecure (32-/64-bit) in the Introjucer? You shouldn't be doing this from within VS.


#9

I am setting the build architecture in introjucer.  I'm merely trying to view the property pages for the build from within Visual Studio... so I can understand why the target folder has moved for the 64-bit build I was doing ... 


#10

So you can appreciate the blankness of it all ... here's a screenshot.  Note the x64 Debug setting in Visual Studio, the 64-bit setting in the Introjucer and the completely empty dialog!!


#11

Ah - I think I've got a work around .... just testing it out.  The blank pages were obtained by selecting Project Properties from the Project menu, or right-clicking and using the Properties option on the bottom of the drop down, or by pushin Alt-F7.   

However ... it looks like the 'Property Manager' can still display the right things ... that'll do for now, but it is a bit funny that it doesn't work 'normally'...


#12

I still get this problem several times a week with latest JUCE tip and VS2013. Very annoying, but the workaround to use the Property Manager as mentioned by @bazrush above seems to work OK.

There’s probably something about the generated projects that Visual Studio doesn’t like.