Build AudioPluginHost for Visual Studio 2019

Hi,

I just started the JUCE tutorials and I am (already) encountering a problem.
I use Visual Studio 2019 and I can’t build the binary file of the AudioPluginHost.
I’m a total beginner here and it is really frustrating as I can’t debbug what I’m coding.
Is there a way to solve this problem ?
I use JUCE 5.4.3 if this information is relevant.

Thanks in advance,
Clomry

What errors are you getting?

You don’t strictly speaking need the Juce AudioPluginHost to debug your plugins, almost any other 3rd party host (Cubase, Logic, Reaper, FL Studio etc) should work too. You can also build a standalone application version of your plugin. However, if you are having troubles building the Juce AudioPluginHost can mean your build system or settings are not fully working at the moment.

In JUCE\extras\AudioPluginHost\Builds, I only have Visual Studio 2013, 2015 and 2017 folders (plus MAC, Linus and Android).
When I try building the solution from the Visual Studio 2017 in Visual Studio 2019 I get the following errors :

Message :
‘iid’ : redefinition ; multiple initialisation (compilation of the source file …\JuceLibraryCode\include_juce_audio_processors.cpp)
File :
\JUCE\modules\juce_audio_processors\format_types\juce_VST3Headers.h
Lines :
148, 154, 155, 156

Can you try leaving the VST3 SDK Folder empty? This will make JUCE use an embedded version of the SDK, which usually works best.

If there is a greyed path, that means, there is still a path supplied in “Global Paths”. Ideally wipe that one as well…

Actually it should work with an external VST3 SDK as well, but this error comes up from time to time, and usually solved best by using the built in SDK.

1 Like

Thanks a lot !

I solved the problem in two setps :
First I added a new export target of AudioPluginHost.jucer (in JUCE\extras\AudioPluginHost), which is done by selecting “Exporters” once the file is opened and clicking on the add icon.
Then I left the VST3 SDK Folder empty, as you advised me to do.

I still wonder whether it’s better to use both built in VST3 and VST2 SDKs, or if there’s no problem using the built in VST3 SDK and Steinberg’s VST2 SDK …

Thanks.
It’s good to know that I can directly debug it using my DAW.
Plus you were right, the settings were not ok.

The VST (Legacy) and VST3 headers are completely separate, so there is no reason not to use the bundled VST3 version.

The VST (Legacy) had to be removed, since that requires now a countersigned agreement from Steinberg, that was only available until last October (2018). But if you have the agreement and the old VST_SDK, you can put it in the VST (Legacy) field, and all should keep working.