Build products copy breaks after upgrading to 4.2


#1

Hello,

I’ve downloaded the latest released JUCE 4.2 (with the latest official Projucer).

My build finishes successfully, but there is an issue with finding the products (it tries to copy them) of the build (.vst, .vst3 etc.) in the post script.

Is there some upgrade procedure I am unaware of?


#2

You are on a Mac, right?

Yes you need to remove that post script. The plugins are now moved into the default folders for the respective plug-in formats (/Library/Audio/Plug-Ins/… ) automatically after build using an Xcode build setting.


#3

Thanks @timur. I apologise for not mentioning I’m on Mac (OS X 10.11.4).
Do I also remove this on the iOS project?

I am now able to build without errors, but running the plugin I get an assertion failure in JuceVSTWrapper::setMaxChannelsOnAllBuses…

busUtils.findMaxNumberOfChannelsForBus(…) returns -1 for a bus.

What do I do to solve that?


#4

You have so set the “Plugin Channel Configuration” in the Projucer ({1,1},{2,2} …) or overwrite “setPreferredBusArrangement” in your AudioProcessor class.

I was looking at the same thing yesterday. When I solved that I was also running into some problems with juce::Atomic. I couldn’t solve the problem yet but I think it’s because I’m using the 10.7 SDK.


#5

Thanks @Jan_Schwers. This solved it, indeed.

I haven’t hit the juce::Atomic thing (I am still a total noob and haven’t gotten to the part where I try to support earlier OS X’s), but if/when I do - I know who to ask first. :slight_smile:


#6

Hm, I think the iOS project should not have a post build script in the first place.


#7

So that’s a “Yes.”, then?


#8

That’s a Yes.

In this specific case, the post-build script wouldn’t do any harm, because none of the AU (v2), VST, VST3, RTAS and AAX plug-in formats are built for iOS in the first place so there is nothing for it to copy. But there’s certainly no reason for it to exist.


#9

Thanks @timur. I appreciate the help.

Cheers!