Can't find 'Build VST' option on Windows 10


#1

I'm a noob to Juce and just checking out the tutorials but I can't get off the starting blocks. I've gone through 'Tutorial: Getting started with the Projucer' and 'Tutorial: Manage your Projucer project' and now I'm on 'Tutorial: Create a basic Audio/MIDI plugin' Part 1 and I'm stuck.

I've installed VST and setup the global config paths. I've created a new project of type 'Audio plugin'. Then it says "make sure that Build VST is ticked". Where do I find this setting? I can't see it anywhere.

NB: On the main IDE I see the 3 tabs: Files, Config & Build but the Build one says "Windows support is still under development". Is this what I'm missing? And if so how can I run through tutorials to evaluate Juce?

I'm using Windows 10 with Visual Studio 2015 Community.


#2

Yeah, sorry, like the message says, we're still working on support for the Windows compiler. We're actually blocked by some LLVM-on-Windows issues, but hoping to get it going soon!


#3

I have Windows 7.......will that fail on my machine too?  Also, what about creating a plugin of a different type, like RTAS for pro tools, etc; Thanks.


#4

You can enable building VST plug-ins by clicking on the top-level project icon in the config tab browser: see the screenshot below


#5

Hey all - I still can’t find the “Build VST” option on Windows 10. I’m working through the tutorials and I’m a bit stuck here. The "Plug-in wants midi input " and “…output” options also elude me.

This concerns "Tutorial: Create a basic Audio/MIDI plugin, Part 1: Setting up "

Anyone know anything about this?


#6

You need to open the project settings by clicking the cog icon next to the project name in the Projucer and then scroll down to the “Plugin Formats” field. The MIDI in/out settings are located underneath in the “Plugin Characteristics” field:

This has changed quite recently so we’ll update the tutorial to make it more clear.


#7

Thank you! That makes sense.