Can't get JUCE VSTi to show up in Cubase? (resolved)


#1

I’m now in the “musical” phase of my JUCE synth use, in that I’m trying to get things working in my DAWs so I can use the synths I’ve made for songs.

I tried Reaper and everything shows up and works perfectly there with no hassle. However, Reaper is not my preferred DAW (Cubase is at this point).

I tried Sonar and while the synth shows up and is usable, none of the knobs/parameters work properly. I am guessing it is requiring all plugin parameters to be between 0 and 1 as I understand some older DAWs do perhaps? My parameters range from -60 to 200, etc. I’m not sure but it’s not that important since I don’t intend to use Sonar going forward and it’s basically a dead application.

Cubase Elements 9.5 is the one I want to work, and there the synth is not showing up at all. When I tried rescanning the VSTs the first time it said “one new VST found” but I’m not sure whether it was my synth or not, since I can’t find my synth anywhere. I’ve confirmed it’s scanning the right directory. It’s a VST3 (.vst3 file) built in Visual Studio 64 bit. It’s not in the blacklist. It’s just not there at all.

The same problem is happening in Ableton Live 9. It is just not showing up. But I can find on their website that:

Make sure you’ve installed VST2 or AU2

  • VST3 and AU3 are not supported in Live.

Is there any reason this might be happening in Cubase? Thanks.


#2

Got it to show up. Cubase is tricky and requires the VST3s to be installed to:

C:\Program Files\Common Files\VST3

so even if you’re scanning it from another directory it won’t find it unless it’s there.


#3

Okay so I take it back. It doesn’t appear resolved. I got one synth to work this way by moving it to that folder. But now I tried adding another .vst3 for another JUCE synth to that folder and it won’t see it again. I’ve restarted Cubase, rescanned etc.

Just upgraded to Cubase Elements 10 and still no help.

Again Reaper finds it instantly and it works normally.

Is there some trick to making this co-operate?

Edit: I think I didn’t enter enough identifying info for each project in Projucer, so Cubase is seeing both synths as identical. I will try adding the 4 digit codes etc. and retest.

Edit 2: That did it. I needed to put the 4 digit plugin code as different between the two plugins or Cubase thought they were the same and would only allow one at a time. So the two issues were that, and also making sure the VST3 files were in the Common Files folder. Problem completely solved.