Choose application to open .sln files issue

Hi there, I’m new with JUCE, with Projucer i can’t save and open in IDE a new GUI code, when I click the VS IDE button it appears me a prompt with the banner “choose application” “new project .sln choose the application to open this file with” and it doesn’t let me choose any application, can you please tell me what’s wrong? How can I solved that problem? thanks in advance

Try resetting the association, if you can’t do this then VS may not be installed properly: Visual Studio version selector always chooses preview version - Microsoft Q&A

thanks for answering, i tried what you told me but i had no success, what it could be?

At the top of the Projucer Window, is the “Selected Exporter” set to your version of VS?

The button does nothing else than “running” the sln file. I would try in explorer to double click any sln file and fix it there. Open with might be an alternative.
Once this works, it should work from Projucer, if VS is selected and a VS exporter is present.

1 Like