Codeblocks can't find juce header


#1

Okay, don’t want to mix this up with my thread from this morning (Invalid/missing parameters in body) but since nobody had an answer so far I decided to dig into that myself. So, I installed Codeblocks on my Pi in order to be able to debug the issue but can’t get Codeblocks to compile my project because the CCG compiler can’t find the juice header files. Okay, probably my bad but it behaves the same if I try to compile the juce demo or the Producer. Surprisingly I got the same issue if I use Codeblocks on Mac. Damn…

…/…/JuceLibraryCode/JuceHeader.h|18|fatal error: ‘juce_audio_basics/juce_audio_basics.h’ file not found|

Must be something trivial, right?
I am still on juice 4.3.0 using Producer to set things up.

Any idea?

Edit: I should mention that I was using Producer to create the Codeblocks target. And, my project compiles fine if I use “make” from command line.

Thanks
Joerg


CodeBlocks pig-config change?
#2

We are aware of this problem and it will be fixed soon. For now you can manually update the header search paths in the Code::Blocks project configuration to get past the errors. You’ll want to add the JUCE modules directory.


#3

That did the trick, thanks Tom!


#4

Mmh, facing a new issue with Codeblocks on Raspberry, this time with the linker.
It is now throwing the message: “undefined reference to symbol xgetwindowattributes”.
I googled for a solution but couldn’t find a solution that works and
since I am not familiar with Linux, I need some hints from the experts.

Thanks!


#5

That would indicate an X11 linking problem. Two things to check:

Do you have all the dependencies installed?

If you look at the linking stage do you see -lX11 in the list of arguments?


#6

Just hit the same error.

Thanks for adding CodeBlocks support!


#7

Thanks t0m, adding X11 to the linker settings solved that issue but now I got “undefined reference to FT_Init_FreeType”. I have installed all libs from the thread you’ve pointed to, also Freetype. And again, using LinuxMakeFile compiles w/o any problem.


#8

OK, fixes for both are available on the develop branch.

Edit: That is a fix for include paths and a fix for libraries.


#9

You guys made my day! Thanks, basically “off the box”-working. Thanks and good luck for 2017 to the juce team!