First new project: fatal error: JuceHeader.h: No such file or directory 26 | #include <JuceHeader.h>

Problem is as described in the title:
fatal error: JuceHeader.h: No such file or directory 26 | #include <JuceHeader.h>

Working with VS Code (not Visual Studio).

Created my first project (audio template). I did not tamper with any files, only changed the global path settings because JUCE did not accept the defaults (see image).

DemoRunner.exe works fine.

Entering g++ -std=c++17 *.cpp at the terminal, with either Linux terminal or VS Code terminal, for either my new project or a demo example, I get the error

Tried moving JuceHeader.h into the same folder as main.cpp & maincomponent.cpp

More particulars:

  • New installation of JUCE on Fedora 35 (35 is latest version)

  • new project is called “OtoDecks”

  • gcc (GCC) 11.2.1 20211203 (Red Hat 11.2.1-7)

  • cmake version 3.22.0

  • Use Global AppConfig Header: Disabled

  • Include BinaryData in JuceHeader: Disabled

I am allowed one screenshot:

I would appreciate any guidance

Randy

More information:

In parallel with this issue I have been trying to correct a CMake problem:

*it cannot find several packages (see attached image)

  • it cannot build juceaide

As you know Fedora 35 (& 34) has pipewire instead of pulseaudio. I am unsure if this is a contributing matter but it seems peculiar it cannot find “alsa”.

My attempt to install two missing modules:

sudo dnf install webkit2gtk-4.0

sudo dnf install gtk±x11-3.0

resulted in “module not found”

Please refer to

for which dependencies to install before building a JUCE project.

I am having trouble installing the dependencies on Fedora.

Your instructions work for MX Linux, a Debian-based distro, but not for Fedora 35.

As you know the commands have to be adjusted for Redhat distros: e.g; sudo dnf update for Fedora 35.

sudo dnf install libasound2-dev , as one example, returns “file not found”.

I find Fedora to be is a rigid distro compared to Debian distros I have worked with.The Fedora repository is limited, JUCE is not found there and - unlike the synaptic repository - the libraries and dependencies JUCE needs are not found there.

Any advice on how to handle this is appreciated.