Compiling AAX Libs on Mac


#1

Hey, its me again, sorry to bother so much…

I installed and compiled the AAX libs on my windows machine and it worked fine, so I was able to compile my plugin as aax.

On MacOSX I do not seem to get the compile running. The DemoRunner and stuff was easy als as a VST3 or standalon app everything worked so far.

When trying to compile the AAX libs on mac it tells my that the pragma push alignment has been changen by an include (6 times for different includes)

Any Idea anyone?


#2

This sounds like a new warning from clang that the JUCE code is not yet disabling when including the AAX headers. Could you copy-paste the output of compiling include_juce_audio_plugin_client_AAX.mm?


#3

Hello there,

its not Juce yet its just compiling the AAX DEV sdk libs that avid provides for aax development on a mac. I compiled them on windows using visual studio 2017 and it worked.

I will post the entire error message later when I get back to my mac.

Thank you!


#4

When compiling the AAX SDK, you can simply disable all warnings.