Compiling JuceDemo App with QuickTime enabled


#1

Hi,

Has anyone compiled juce (1.39) demo application with QuickTime flag enabled in juceconfig.h.

Our application which uses QuickTimeMovieComponent works fine when linked against juce 1.27. When I linked with juce 1.39 it throws up linker errors.

Anyone faced such problems ?

TIA
Shivanand


#2

not tried it myself i’m afraid, as i’ve currently no purpose for it. have you tried doing a clean and rebuild? i needed to do one anyway with juce 1.39 from the name of the lib file changing (adding a Win32), which a clean and rebuild solved.


#3

Yes, I have tried clean and rebuild but to no avail.

I replaced the new QuickTimeMovieComponent code with the old one, it worked but with few gliches.

Seems like inclusion of ActiveXControl in QuickTimeMovieComponent has broken something.


#4

Nothing is wrong with the source code - I obviously always check it in various different IDEs, and the pre-compiled juce demo on the website has OpenGL in it.

Must just be some strange setting on your machine - check your library + include paths.


#5

It works :slight_smile:

Thanks
Shivanand


#6

magic!


#7