QuickTime Flag Not Enabling


#1

I’m on XCode. QuickTimeMovieComponent is not showing up in my project as a class type. It’s also not showing up as enabled in the Juce Demo. From browsing this forum I learned that it must be enabled in juce_Config.h. Looking at that file, I find:

#if ! (defined (JUCE_QUICKTIME) || JUCE_LINUX || JUCE_IOS || JUCE_ANDROID || (JUCE_WINDOWS && ! JUCE_MSVC)) #define JUCE_QUICKTIME 0 #endif

so I changed it to:

#if ! (defined (JUCE_QUICKTIME) || JUCE_LINUX || JUCE_IOS || JUCE_ANDROID || (JUCE_WINDOWS && ! JUCE_MSVC)) #define JUCE_QUICKTIME 1 #endif

I then rebuilt the juce library as well as the demo, but still no quicktime enabled in the demo, and still no QuickTimeMovieComponent class available to use in my project.

I’ve tried clean and rebuild, downloaded the latest JUCE version, nada. And just to make sure that my editing of the config file was having any effect, I disabled the JUCE_WEB_BROWSER. And when I rebuilt the juce demo, I got a bunch of errors. So it looks like everything’s connected properly. What am I missing?


#2

There is no quicktime in 64bits OSX AFAIK


#3

I’m not specifying 32 or 64 bit, so I’m not sure if that has anything to do with it. I’m just trying to get QuickTime to work in whatever way it can. Plus, the latest QuickTime runs both 64 and 32 bit.


#4

by default if you run an Universal binary, it runs the 64bits version.
The version of QuickTime used in Juce is only available in 32 bits.

my 2 cents


#5

Ah. Good to know.

Got it working in my project. Stupid mistake. I was changing the flag in the main juce library, not in the amalgamated file within my project’s folder. duh.

But, still no demo. And I’m definitely changing the right flag for that.