Debug Ableton Live - Can't output anything to the console (macOs)


#1

Hi,

I’m trying to debug my VST plugin inside Ableton Live, but it seems that I can’t output anything to the console.
I’m using Xcode 8 and running ableton process through Xcode
20

If I run Ableton through my macOS terminal it doesn’t output anything as well, unlike Reaper.
Does anyone know why ?
Is it because Ableton load vst inside a sandbox like Bitwig ?
Is there any solution ?

Thank !


#2

Not at my Mac currently, but don’t recall having any issues with this tbh


#3

BTW, did you try debugging as root?
Also, does you see any breakpoint stop as expected?
It might be you’re trying AU instead of VST (or vice versa)? Did you check no conflict with user plug-ins vs shared / global plug-ins folder?


#4

I’ve experienced this while changing the name of a project in xcode without updating the name of the project in projucer… perhaps try regenerating your project with the jucer.


#5

Hi,
Thanks for the responses.
The Breakpoints work with Xcode.
I’ve removed all other related vst (from MacintoshHD/Library/Audio/Plugin) and leave the one in my user library. Juce still export it via a symbolic link, but I don’t think it could be related. I’ve also tried to rename the project and reload it.

What seems strange is that I can’t see any debug from plugins in Ableton Live.
I’ve tried with other juce projects and commercial vst that output things, but nothing.
So it’s maybe more related with my ableton installation instead of juce.
Is there any Verbose/Debug flag in ableton ?

Thank !


#6

Okay,
I went for the radical solution by formatting my laptop. After a fresh install, everything ok.
So I guess solved but I don’t know where could this bug come from… Maybe my Xcode 8.3 version ?
Everything running ok with the 9.3 except that there is no convenient way to fold bracket / method.

  • But that’s another thing eh.

Anyway, thank everyone for the help !