VST3 plugin not visible in DAW

Hello,
I am following the very simple tutorial for building a VST plugin (JUCE: Tutorial: Create a basic Audio/MIDI plugin, Part 2: Coding your plug-in). I am able to load the plug-in in JUCE’s audio plugin host, but I’m not able to see it in my DAW (ableton). I have rescaned the VST folder (Library/Audio/Plug-Ins/VST3), but still nothing showed inside ableton’s plugin tab. Am I missing certain configurations? I am on MacOS BigSur.
I am using projucer 6.0.8
Thanks!

Solved! I made a release version and then it’s visible in Ableton Live. I wish they mention this in the early tutorial too. It could save people time from running into this issue.

Solved as long you want to work with the release build, but you can’t debug that properly. Have a look at the option “Enable Plugin Copy Step” in Projucer :wink:

Thanks a lot! Indeed it would be great to run the debug build with ableton for debugging purpose! I just tried enabling that option and used the debug build. But it’s again invisible in ableton. Is it possible that there are other options that I need to modify?
In the xcode config, the only differences between debug and release mode is optimisation and link time optimisation. So I wonder if it’s something else.

As long as your path is right that should work. In your first post you mention your path is

But in the picture it is Library/Audio/Plug-Ins/VST3

sorry, it is like you said Library/Audio/Plug-Ins/VST3. As soon as I change it to release build and rescan the vst3 folder in Ableton’s preference, the vst can be detected. So I think the path should be fine.

@gustav-scholda may I ask if you are also building yours on Mac 11.* (Big Sur)? I built an example plugin (GainPlugin Demo) as a debug version, and notice that it’s visible in Mac 10.* (Catalina) with Ableton and JUCE’s audio plugin host. But on Mac 11.2.2, it’s only visible in JUCE’s host but not in Ableton. As release version everything works fine tho.

I’m building on both Mac and Windows but I’m not using the projucer, I use cmake. Sorry, I don’t know what else to try, weird that it doesn’t work on your side…

Have you tried to shutdown/reboot your computer? I’m not a plugin expert. But IIRC when i was building the tutorial’s plugins (Projucer / Xcode / Big Sur) it was sometimes required to restart to properly localize them (in Ableton/Bitwig…). Very annoying. I didn’t found a way to fix that (but as i don’t make plugins for now, i just gave up).

thank you! I did restart as you suggested but I still cannot see the plugin in ableton live11. I wonder if I’m the only person in the universe using this combination Live 11 + projucer + BigSur. I didn’t change anything in the setting but it doesn’t work. but strangely nobody else complaints about it. I only hope the juce people see this post, or maybe I should try to contact them directly.

I did restart as you suggested but I still cannot see the plugin in ableton

:frowning_face: … I’ll try later to see how it works on my computer nowadays.

but strangely nobody else complaints about it

Such annoyance was usual on macOS, that’s why i didn’t complain at that time.

I don’t know if it is supposed to work reliably out of the box on Big Sur.

I only recall having to restart (or take other actions) for AU plugins. But sometimes you have to rescan the VST3 folder in certain hosts, I believe.

1 Like

thanks for the reply! I did scan the vst folder but my debug build never show up there. The release build works fine tho.

I did a quick test with Bitwig and it works fine. I didn’t tested with Ableton (IIRC i have uninstalled it to make room on my mac).