JUCE VST doesn't show up in Ableton

Hi,

I’m just starting with JUCE (v6.0.1). I’m following a tutorial to build a basic gain slider.

I’ve set the scheme in Xcode (v11.5) with Ableton (v10.1.15) as the executable, but when I build nothing shows up in Ableton under the VST3 plugins. In the Xcode output I see a few warnings:
Live[3485:109919] [plugin] AddInstanceForFactory: No factory registered for id
HALC_ShellDriverPlugIn::Open: Can't get a pointer to the Open routine 2020-07-08 14:32:00.856696+0300 Live[3485:109919]

Any ideas?
Thank you,
Alon

Does it show up in any other host? Maybe you forgot to enable the plugin copy step in the Projucer so that the generated VST3 is not copied over to the Folder where Live looks for it…

The Enable Plugin Copy Step is enabled, and I verified the VST3 Binary Location as well. Actually, it doesn’t look like the VST is copied anywhere after build…

does xcode have access to the copy directory? If your username does not have write access to that directory it might not be able to copy. I ran into an issue on windows where visual studio didnt have access to the copy directory, so I ran VS as administrator and the copy step was able to complete.

Try making the copy directory something like ~/Desktop and see if it copies the files there.

1 Like

@stonepresto I’ve changed the copy directory to ~/Desktop and it builds successfully, but it still does not copy the files there…

I dont have a mac to test on, but I just tried on linux and everything copied as expected. Are you sure you configured the copy step for the right exporter and right configuration? It could be an xcode thing as well I guess. Try and make sure that the directory in the copy step directory actually exists. If it doesnt exist it might not work.