Drag And Drop issues


#1

So i managed to build the Demo on Linux (Ubuntu 12.04 with MATE desktop) and the drag and drop demo tab is not working when dragging rows from the demo table to the target. It catches external drag and drop events, but the internal ones are not working (i get the same behavior in my app but i wanted to verify that). All the virtual events for the DragAndDropTarget object are silent although all the mouse events are getting triggered.

It looks like sometimes it works though, i noticed that if I right click on the target component first and then do a drag&drop event it works, but only once after the click.

Also when i DROP the actual item, the main demo window looses it's focus for a brief moment (weird?)


#2

Yes, I think I've seen similar behaviour on my Raspberry Pi (Rasbian) - The Drag demo did (sort-of) work - sometimes you had to pick-up the drop-down item and entry to the drop target wasn't always detected (red-surrounding box). Also, external file drops don't appear to be detected


#3

Sorry to bring this back but this is not working as it should. I'm attaching a Hello World app with a few lines of drag and drop code to test, it's an introjucer project that just prints the events if you drag from the top to the bottom component.

 

There are no events for mouseDrag() mouseMove() when the drag event occurs on the target component, only when you release the button those event start to appear.

 

project http://ctrlr.org/Dragg.zip


#4

It looks like this is affecting other OSes

OSX and Windows XP are also affected

Windows 7 looks to work fine.

 


#5

Tried your demo app but failed to see any problem here on OSX..


#6

Well it's failing here on a 10.7 macbook pro

also on my VM windows XP and a linux workstation i use at work.


#7

Ok, try it again now..


#8

No change in the Juce Demo after re-building the project, also Dragg seems to be broken too (linux x64 ubuntu 12.04 with mate), git log

 

[r.kubiak@AMDC2543:~/devel/JUCE]$ git log -3
commit 4d30e810e828762b281591e3a53e76655247a1ad
Author: jules <jules@rawmaterialsoftware.com>
Date:   Tue Sep 16 08:43:03 2014 +0100

    Avoided a compiler warning

commit d9e31b907029c7a047132c7a8026b0b299bb97ce
Author: jules <jules@rawmaterialsoftware.com>
Date:   Mon Sep 15 21:57:52 2014 +0100

    Fix for a ref-count issue in VST2 plugin windows

commit b7d922d4d13ef508601a4dd1abbe57b9da0b7df1
Author: jules <jules@rawmaterialsoftware.com>
Date:   Mon Sep 15 18:53:34 2014 +0100

    Improved the way sliders react to vertical/horizontal mouse-wheel moves.


#9

Definitely works for me now - I did replicate the problem in linux, and fixed what I saw.

So not sure what you're seeing now, but maybe it's a different problem that I'm not getting here..


#10

I'm sorry you are correct, i had to clean up my local JUCE copy and then it worked fine.

I'm sorry for the confustion, and thank you for your fix.