File drag on Windows not working


#1

I just tested the DragAndDrop demo on Windows today (latest git version) and it seems the file drag doesn’t work anymore.


#2

It doesn’t do a file drag, does it? The DragAndDrop page is just an internal drag demo…?


#3

The green box says that you can drag files to it, also the file drag and drop code is in place but it never get’s triggered.
It works fine on OSX.

btw i tested on Windows 7 Win32


#4

Well, I just tried that and it worked fine too. (I’m using the modules branch)


#5

I just got the latest version using GIT as stated on your download page, you might want to check if it works using that branch as new users don’t know a ‘modules’ branch exist.
But do you mean i now have to check two repositories each time i find something that does not work, i hope not.

Just to be clear:
If you get the latest version from GIT using:
git clone --depth 1 git://juce.git.sourceforge.net/gitroot/juce/juce
and run it on Windows 7 32 bit the file drag does not work.


#6

i had/have a similar issue (http://www.rawmaterialsoftware.com/viewtopic.php?f=3&t=7551), but, sometimes it works, sometimes not…


#7

I think you might just be seeing the same thing that chkn mentioned - there’s just something a bit weird about windows dragging, sometimes it just doesn’t send any events to the app at all, depending on whether it has focus or not. I looked at this a while ago, and also saw the same behaviour in non-juce apps, so I don’t think it’s something we can fix…