Flock.cpp missed (wrong location) - Plugin host


#1

Hello,
I have problem with Plugin Host example app. As I wrote in subject, while I compile the program in xCode, there is error, that flock.cpp can’t be found.
I’ve just read topic in that link:

There is advice to install latest version of SDK VST, but I’ve just download it from https://www.steinberg.net/en/company/developers.html
and it doesn’t help.
So I tried to move flock.cpp file to location where xCode expects it but then there are much more errors. I also tried to change #include path to the location where flock.cpp comes originally from steinberg. But it also doesn’t help but gives much more errors.
I can’t find anywhere explanation how to repair it. Could anyone help me?
For any help thanks in advance.


#2

As we said on multiple other threads:

  • get the latest VST version 3.8
  • get the latest JUCE version from the develop or master branch

Don’t mess around trying to move files or fix things yourself!


#3

Hello,
thanks for reply, but where to find latest version of VST 3.8
On the official steinberg website there is only VST 3.6.8 - here: https://www.steinberg.net/en/company/developers.html

And I have also installed JUCE 5.2.0, isn’t it the latest version?


#4

Sorry - that was a typo, I meant 3.6.8

And no, whenever we say the latest version of juce, we mean the develop or master branches on github!


#5

OK, thanks,
but then I have one more stupid question, sorry for that but I am quite new on github and in programming at all. So I would like to ask: I found that https://github.com/WeAreROLI/JUCE

But I am not sure shoul I download all files from that link, or it’s enough if I download only Plugin Host files from here https://github.com/WeAreROLI/JUCE/tree/master/examples/audio%20plugin%20host


#6

You can’t really be a developer without understanding GIT these days, so that’s worth spending some time learning!

And yes, you should always pull entire repos as a whole (this applies to everything, not just juce!) If you start mixing up random versions of files from them you’ll end up in a mess.


#7

Hey,
great thanks for your support, now works perfectly.
Thanks and happy new year :slight_smile: