Installing Juce, trying to build the Plugin Host - compiler errors on the Steinberg VST3 code


#1

Hi,
I’ve installed JUCE,
the latest (3.6.8) Steinberg VST3 SDK from https://www.steinberg.net/en/company/developers.html ,
and I’m trying to compile the plugin host.

This gets me the following error:

1>------ Build started: Project: Plugin Host_App, Configuration: Debug x64 ------
1>include_juce_audio_processors.cpp
1>d:\dev\thirdparty\juce\modules\juce_audio_processors\format_types\juce_VST3Headers.h(98): fatal error C1083: Cannot open include file: ‘base/source/flock.cpp’: No such file or directory
1>Done building project “Plugin Host_App.vcxproj” – FAILED.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

And after carefully checking the VST3 SDK folders, that’s pretty damn right - there IS no base/source/flock.cpp

Has this file been removed from the SDK and is JUCE not up to date?
Or am I doing something very very wrong?


#2

Hi there. Maybe this thread will help?..


#3

Please try using the develop branch from GitHub. We haven’t yet updated the master branch to use the latest VST SDK, but that’s something I hope to get done today.


#4

OK, the master branch has been updated too.


#5

Sorry, i have the latest VST SDK, the latest VS2017 and the latest JUCE, downloaded now after:

I still have this error.
what do I do?


#6

Ah, the version of JUCE you can download from our website is only updated when we do a release. You can get the latest changes from here:

Click the green “Clone or download” button.


#7

The quick “irresponsible” solution that worked for me was getting the 3.6.7 version from the Steinberg repo:

You just have to clone the repo and checkout this commit:
https://github.com/steinbergmedia/vst3sdk/commit/13afc58c10a0e394004b2566f905862e65084f79

After you do that just hit a git submodule update --init --recursive to make the sub repos point to the corresponding commit too.

It worked for me, but beware your using old code… :confused:


#8

ahh…
it was fixed, nice!!
anyways, if you’re sticking to an older version of JUCE, that an easy solution just in case…


#9

Or the shortcut in one go:
git clone --recurse-submodules <REPO_URL> <LOCAL_PATH>