Getting error while compiling


#1

Hello all,

I am recompiling my plugin on a mac which works great on a PC but I can not get it compiled now on my mini-mac.

I am using 3.2.6 Xcode, the latest modules using the introjucer to build the files. I have the idea I have broken something very basic but I can not get my head around it. I probably just need a push in the right direction.

I get the next errors in this part of the code (Allpass2Filter.cpp):

class Allpass2Filter : public AudioProcessor, public ChangeBroadcaster { public:

Also AudioSampleBuffer, Midibuffer, MemoryBlock etc are not declared.

What do I do wrong? It is probably something very simple. Thank you for your help.

Harrie


#2

“using namespace juce” ?


#3

When adding "using namespace juce to the .h files the compiler tels me that juce is not a namespace type.

I did place the code here before the namespace code of the Allpass2 code:

[code]
#ifndef ALLPASS2FILTER_H
#define ALLPASS2FILTER_H

using namespace juce;

namespace allpass2Filter
{
enum
{
kgain=0,
kdelay,
kNumParams
};
}[/code]

I see tht the jucedemoplugin compiles. Anyone more directions I should search? Thank you!


#4

Seems like true basic programming mistake; you aren’t including any juce files!

Try including the juceheader? #include "../JuceLibraryCode/JuceHeader.h" You might have to tweak that path though


#5

Yeah I am really a noob with this (mac-)stuff. I am lucky with this forum so I can ask for ideas. Sometime very simple things can take ages to fix.

I tried that #include "../JuceLibraryCode/JuceHeader.h but got the same error. I saw that thee demoplugin uses that. Is using an include.h with “using juce” inside another option?

Thank you for your help!

Harrie


#6

Like I said, you might you have to tweak that path. As in, you might need more …/, or less, depending where your file is placed in relation to the JuceHeader.h file. There are no other options…

With that, you’re missing a " at end of that line of code.

This mistake isn’t specific to Macs, nor is to developing on Macs - it’s simply a C++ code error. No offense, but it seems that you require picking up a book on programming in C++.


#7

Have you checked whether the Juce code (“Juce Library Code” & “Juce modules”) is actually included in the project, e.g. the folders in the project include juce_core etc.?
I sometimes had the problem that the IntroJucer didn’t find the Juce modules and thus didn’t included them (though I mainly saw this on Windows, I think if Juce is on another drive than the project).

Chris


#8

It is fixed. It was super simple item with additional …/… I did not understand the directory structure. :slight_smile: Thank you for helping me. It is now building fine.

Harrie