GUI not displaying in Unity

Hi All

Currently trying to start work on my first plugin with JUCE and have found myself in a bit of a jam.
My plugin is going to be for Unity but having created a new JUCE project and compiled as a test I’ve found that I can not see the GUI. I’ve followed the Unity Native Plugin Support article but can’t figure out the issue. I’m on macOS 10.13.6 and have tried with Unity 2019.1.0f2 and 2019.2.9f1. Any help would great.

Just had someone else try my bundle on their laptop but the GUI will not display for them either. I’ve compiled it as a VST3 and all the GUI is show as intended. My friend is downloading JUCE tonight and will attempt the same to see if it is related to my version of JUCE.

I’ve also noticed the .cs file in the bundle that is responsible for rendering doesn’t seem to be treated the same way as scripts made by unity. On both the computers tested it displays differently in the project folder and when you try and open it, it opens in the computers default IDE rather than the one designated for Unity. Is it possible that it is not being compiled by Unity or is this all normal behaviour?

Hi Joshua2880,

I happen to have the same problem. I built a trivial Unity plugin on windows and it worked without problems, then I built the same JUCE project on a Mac, version 10.14.6, but on Unity there is no GUI. The plugin is recognized correctly and I can load it on the Mixer, but the GUI is simply not showing up. I tried both with JUCE GUI and Unity standard GUI.
Did you find a way to solve the problem? Did anyone experience the same problem?


For anyone interested, I solved the problem. I did as suggested in this topic:

I moved the C# script associated with the plugin from the inside to the outside of the bundle and everything worked.

Nope never got It to work as but was focusing on another part of my project. I’m actually in the process of figuring out an alternative strategy as the current integration seems very limited. Thanks for the answer though.