Header includes problem


#1

Hi, I’m trying to get a project working in projucer, I was just trying to compile a template project (I also tried several of the demo projects but had the same problem) but I always get an error saying ‘memory’ cannot be found, pointing to a line in the includes section for #include. I read every topic I could find on this forum about it and verified that the path in the compiler points to the folder with the memory.h file in it. I was even able to get that error to change temporarily by changing it to #include<memory.h> but then it just gave an error on the next header include for cmath and changing it to cmath.h didn’t work. I’ve reinstalled mingw, reinstalled juce and tried getting a project to work in code blocks but I cannot for the life of me figure out how to get projucer to recognize the header files.

My mingw is the latest 64bit version and is installed in the code blocks folder. I checked the path in the projucer compiler settings as well as my windows path and both are correct. I made a test cpp file with includes for memory and cmath in codeblocks and it ran with no problems. I’m on windows 10 64 bit.

Does anyone have any idea what I could do to make it work? I’d really like to use juce since all of the other vst programming solutions I’ve found are much more complicated. Any help would be great. Thanks.


#2

Are you trying to compile the projects in the Projucer using the live-build engine? You’ll need to install Visual Studio 2017 and the C++ desktop development tools that it comes with in order to use it, it won’t work with MinGW.


#3

Ah, ok. Thank you for your help. I just saw an option in JUCE to use codeblocks so I assumed it would work. I installed visual studio and was able to get it working.