How to debug auval?

My plugin failures the validation with auval (when side-chained added)
Now I trying to debug auval.
I had to copy auval outside /usr/bin to make it accessible from Xcode.
Then i setup auval as executable in Xcode in the Scheme configuration
But when i try to start debugging i get
–> doesn’t contain the architecture i386
–>doesn’t contain the architecture x86_64
as error from Xcode (wheter i choose the 32bit or 64bit environment)
Any help appreciated :slight_smile:

You need to use auvaltool instead of auval (the latter is only a script that call auvaltool). If you create an alias for /usr/bin on / you can also select auvaltool directly from xcode.


Oh Thanks! Still not knowing what breaks validation, but one step further :wink:

Great, that helped me.

One thing to add, since 10.11 the debugger will not be able to debug auvaltool:

Message from debugger: cannot attach to process due to System Integrity Protection
Program ended with exit code: -1

The solution is to copy auvaltool over to the /Applications folder (and possibly rename it, to avoid confusion).


Hi, I’ve tried copying this to several locations and the debugger still cannot attach (although don’t get the SIP error) - is this working for you on 14.4? thx

1 Like

Just linking to another thread in case anyone needs the latest solution: