Improvements for ProJucer


#1

I'm trying to get my project to build with ProJucer. It builds fine i xcode7 so it should work. I get a few errors though.

The problem is I can't really see the cause of the problems. I really miss seing the stack leading to the errors.

I get quite a few files (including from JUCE) giving the error "enumerator evaluates to -<somethingreallylow> which cannot be narrowed to uint32_t".

Oh b.t.w. feature request, be able to copy paste from error messages/build output.

Something like a raw llvm/clang output or better handling of the full error would make troubleshooting a lot easier.


#2


#3

In a nice xcode manner it points to the wrong line :)


#4

It's surprisingly hard to get the line numbers right!

Thanks, we'll see what we can do. Usually it seems to go wrong when there's a mix of CR/LF characters in the file, or if you're editing it while the compiler's going.


#5

Hello! We submitted a fix for the enum narrowing issue some time ago, are you using the tip?

Hope this helps.


#6

This is the latest avaible from http://www.juce.com/download, tested today.

Finder says ProJucer was build 4th of November. ChangeList.txt says 4.0.1

I had to google to find that page though... is there a link on juce.com? "Get JUCE" is not get juce at all, it's buy JUCE.

It would be nice to have a version number in ProJucer GUI b.t.w.


#7

(We're building a 4.0.2 later today)

In Projucer, if you close any text editors, there is a version number on the window background, under the logo.

 


#8

Perhaps we should make the version number more apparent, you're not the only one to miss it.


#9

I've totally missed that one. Looking forward to try out 4.0.2.

It might be good to add the version number to the zip-file and/or the download page too.


#10

I'm running 4.0.2 here now and no difference. Same errors as before.


#11

Same Error again and again and again....


#12

anyone know what's going on with these enum errors?


#13

Try to update your JUCE repo, Jules commited a work-around for these..


#14

I just downloaded the 4.1 version on ProJucer and updated the modules as well.

I'm not sure if the enum-issue is solved or not since the compiling goes on for some files and then crashes.

The error cleans away which files were built and say:

"

Jit process crashed!:

Invalid abbrev number

"

and a restart-button.

 

 


#15

....and there I manage to get the build to go all the way through, with the only difference is that I turned off "show warnings".

 

.. so the enum issue seems to be solved indeed, nice!.

Now you have another issue instead ;)