Installer issue with AU component not being installed (but VST and AAX are)

[maybe not directly related to JUCE itself, but more to installing the JUCE plugin end products, and I think some of you might have run into this as well, hence my question here…]

I was switching back and forth between different versions of a plugin, by simply running the installers (needed to test some backwards compatibility things). The installers contain a VST, AU and AAX version of the plugin, and I’m using Packages from Stéphane Sudre.

Apparently, when you do the following, a user can get into a strange “mixed up” situation, where the VST and AAX format of the plugin got installed properly, but not the AU version:

  1. run newer installer with newer plugin versions (say 1.1.4)
  2. run older installer with previous plugin versions (say 1.1.3) (downgrade)

→ both installations run fine without showing any errors
→ VST and AAX are now at version 1.1.3, but AU is still at 1.1.4

Given earlier mentioned issues here on the forum with installing AU plugins on macOS, I also tried to reboot my system, but that didn’t help…

But then I ran the installer from the command line, and noticed this in the output:

<Info>: PackageKit: Skipping component "com.MyCompany.MyProduct" (1.1.3-1.1.3-*) because the version 1.1.4-1.1.4-* is already installed at /Library/Audio/Plug-Ins/Components/MyProduct.component.

There was no such line for the VST or AAX plugin bundles, only for the AU version.

Does someone know a good solution to this problem?
Are there options to disable this “skipping” behavior?
How do you handle this in your installers?

(I realize installing a previous version probably doesn’t happen a lot, but if a user wants/needs to install version X of my product, he/she should then also have version X effectively installed, OR see an error if that’s not possible, but not a mix of downgraded VST and AAX but not AU, which can be pretty confusing)

I think you have to enable “Allow downgrade” for the AU bundle in your Packages project, see link below for the screenshot where to find it.

Beware that when you remove a bundle from the Packages project and then re-add it, the “Allow downgrade” checkbox for it resets to unticked, so you have to remember to re-enable it whenever you add a new bundle/binary to the project.
I have scripted that with a good deal of python that parses the Packages project, it’s a .plist file after all

1 Like

Aha, I somehow missed that!
It’s strange though that this is only an issue for the AU plugin, and not for the AAX or VST plugins: all 3 currently have that “Allow downgrade” option unchecked, but it’s not a problem for the VST and AAX…
I also read the other thread you pointed to, and maybe a pre-install script that deletes things first might be even safer. I’ll see how it goes.
Thanks for the feedback!