IntroJucer not adding "browse" folders to projects


#1

Hi I am new to JUCE, I created two modules for my app. But the folders in the modules do not add to the Xcode project? Even though I specified them in  juce_module_info "browse" field. here are my modules

 

https://github.com/nTopology/juce_open_mesh

https://github.com/nTopology/juce_icarus

 

The funny thing is it worked initailly, then I made some changes to the directory structure of the module. Then introJucer stopped adding the folders form the "browse" field. when I update the project via introjucer.


#2

I just found out that the problem is that IntroJucer does not recursivley add folders so if I do this

  "browse":         [ "OpenMesh/Core/Mesh/*","OpenMesh/Core/Geometry/*"]

introJucer will add the files , but if I do this

 

"browse":         [ "OpenMesh/*"]

 

it wont add any files. Is ther a way to recursivly add the files? I tried

"browse":         [ "OpenMesh/**"]  

 

but that did not work. 

 

 


#3

Ah yes - it's not recursive. My approach was that when building a module, it's not too much of an extra burden to make sure you curate all your subfolders correctly! TBH I wouldn't use a recursive search in my own stuff even if it had one, as I like to be sure exactly what I'm including.