Xubuntu & "Not a valid JUCE modules folder!"


#1

Hello,

I'm on xubuntu 13.10. 

I cloned the repository (JUCE v3.0.4) & built Introjucer smoothly (Introjucer 3.1.0) 

But can't create a new project ... 
I saw that there were other post regarding this issue, but none of them seem to specify exactly what to do to fix it. 

http://www.juce.com/forum/topic/introjucer-cannot-find-modules 

http://www.juce.com/forum/topic/cannot-start-new-project-introjucer 

Does anyone have a suggestion?

thx
 


#2

Introjucer need a path to the folder that contains the modules of JUCE. So in the "Select your JUCE modules folder" you just have to select the "JUCE/modules" folder (sibling to amalgamation, docs and extras).


#3


Thank you Nicolas,


But this is the problem! 

Introjucer does not recognize the folder I designate, nor any file in fact 
When I use strace -f -e, I see a series of errors about files not found.

For example: / .icons / Human / cursors / xterm ", O_RDONLY) = -1 ENOENT (No such file or directory)

 

Perhaps missing some libraries? Anyone else has had this problem?


 


#4

Is this on linux?


#5

Yes it is.

-> xubuntu 13.10 (xfce version)


#6

Well if it says the folder doesn't exist, it's probably right. What folder are you giving it?


#7

Sorry,  I didn't explain myself properly.

When the program asks me to specify the folder containing the modules, I do so without problem (I actually clicked on the appropriate folder).

But at that time, the program tells me that this directory is not valid (see screenshot) and then endless loop (forced to kill it to get out of this loop).

I tried to indicate other folder, assuming I did not refer to the correct one, without better results.

So I searched the forum to see if others had the same difficulty and I found the 2 links (specified in the first post).

And also this one: http://www.juce.com/forum/topic/just-compiled-ubuntu-124-however-it-couldnt-recognize-module-folder

So I followed what did Jerome (on this post: http://www.juce.com/forum/topic/introjucer-cannot-find-modules) and found that I had error messages on the terminal.

Also Jerome said: 

However it looks like the communication between IntroJucer and the native file picker window can be garbled by messages on, presumably, stderr.

So I fixed the cause of the messages, and IntroJucer magicly worked

If it's a similar problem, my question would be more: "Does anyone has an idea how to correct an error such as the one specified in the first post?"

Hence my suggestion: Perhaps missing some libraries?

 

thx

 


#8

I have exactly the same problem on Linux-Mint (Debian Edition). The Module-Selection works nice on Windows but on Linux i also get the error you posted.

 

 


#9

Not sure what to suggest about this - it's all working happily on my linux distro..


#10

I had this problem on Ubuntu 13.10. It seems that stderr is interfering with the Introjucer's path selector. As others have mentioned, you'll need to track down and fix the error message that stderr is outputting.

Try launching the IntroJucer and opening one of the example projects. Instead of opening, I got a notification that an IBUS error had occurred. I had to fix that problem in order to get it to work.


#11

Thank you Joel! You're right.

In my case, I tried to open the audio plugin demo and this is what IntroJucer tries to load:

Loading project: /Lib_Cpp/JUCE/extras/Introjucer/Builds/Linux/build/(zenity:3705): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:3274:48: Expected ',' in color definition/Lib_Cpp/JUCE/extras/audio plugin demo/JuceDemoPlugin.jucer

 
So I have to fix this Gtk warning.

...but how?


 


#12

Are you guys sure you're using the latest version? I fixed things a while ago to make sure that when it launches the file chooser, it ignores the stderr output - see juce_linux_FileChooser.cpp, line 137. In your case is it just failing completely because of that error?


#13

Maybe this line:

args.add ("2>/dev/null");

is missing for the zenity caller code ?

 


#14

Good idea! I don't have zenity myself but will add that line in someone can confirm that it works!


#15

I give a try: pull from repository, make, launch Introjucer and try to open a demo project.

log file:


********************************************************** 
Introjucer 3.1.0 --- Build date: Mar 28 2014 
Log started: 28 Mar 2014 8:41:13pm 

Loading project: /home/Apps/Lib_Cpp/JUCE/extras/Introjucer/Builds/Linux/(zenity:4060): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:3274:48: Expected ',' in color definition /home/Apps/Lib_Cpp/JUCE/extras/audio plugin demo/JuceDemoPlugin.jucer 
Shutdown