Introjucer Update


#1

I had a problem using GIT so I tried to get the latest source with the Introjucer. It’s telling me the latest version is around the 15th July though.

Tried this at home and work and I’m getting the same thing. Is anyone else experiencing that?


#2

Jules wrote recently that the Introjucer is getting a makeover and it will take him a few days. For now it’s trying to download the old non-modular version of JUCE witch is 1.53


#3

Oh right, I didn’t realise. Thanks


#4

Hi,

I downloaded a post quake version from MarC’s webpage for the juce workshop in Berlin.
Now, I did lots of changes to my code and don’t want to go back to a pre- quake version as I really like
the new “modules” thing. Unfortunatelly I don’t get the latest post quake version using

git clone --depth 1 git://juce.git.sourceforge.net/gitroot/juce/juce
cd juce
git checkout -b origin/modules

It says something like “Changed to a new brand” once finished but I cant find the new folder structure
inside the juce folder, i.e. I miss the folder called “modules”. Then I tried to use “git checkout modules” instead but
still no success. I am not familar with git at all (and actually don’t want to be as I am just a hobby programmer).
Therefore, is there another, easier way to get the latest post quake version by downloading a zip or so?

Thanks for help!
Joerg


#5

Please see my latest post here:
http://www.rawmaterialsoftware.com/viewtopic.php?f=12&t=7660


#6

I had problems with an older version of msysgit under Windows (thread).

After installing a current version the following worked:

git clone --depth 1 git://juce.git.sourceforge.net/gitroot/juce/juce
cd juce
git checkout modules

Chris


#7

I did “git checkout modules” instead but still, no modules folder :slight_smile: I am not in front of my computer with juce
but if I remember right, the above line causes an error line in git about a wrong path…
I am quite sure that my guit configuration works as I did all the previous juce updates using it.
The only thing I can think of is a old git version. Do you expect a new one?


#8

Thanks Chris,

my reply came in to late :slight_smile:

Will try the new one. Do I need to do re- configure git after update or will it work plug&play?
I remember the struggle to get git working in the first place…

Thanks
Joerg


#9

Okay, updating to latest mysygit and using

git checkout modules

did the trick for me.

Thank you all!
Joerg