Could the JuceLibraryCode folder name be exposed as a configurable parameter in Introjucer?

Could you explain why you need this functionality? This would help us identify if we are missing an Introjucer feature on a higher level.

The underlying goal: Building multiple versions of an application with different configuration (a bunch of #ifdefs).  In my case two versions of the same plugin.

So, what I've done (after a lot of head scratching) is to

  • Script the generation of a second jucer file from the first, modifying the configuration as required.  See
  • Have the second jucer file in the same folder as the first (this is why having a new name for the JuceLibraryCode folder would be useful).
  • Change the target build folders:  ./Builds.typeOne ./Builds.typeTwo
  • Call introjucer --resave on the first version.  Build.  Call introjucer --resave on the second version.  Build.  Package both.

Anyway - this works, I can now build the two versions and do all the packaging automatically, but I have to be careful when doing development as I need to make sure the correct AppConfig is in place for the version I want to test. 

I did try using symlinks so that the same source structure was exposed in two different folders, and both jucer outputs could use different JuceLibraryCode folders. 

Anyway ... hope that helps.  It might need a whiteboard to explain properly...