Is the tip actually compiling plugins at the moment?


#1

I just grabbed the latest tip at around 1800 on 7th May 2009 and built the demo plugin for vst only on both mac and win. Neither of them work, they don’t show up in Live at all even though they get scanned. Can anyone please shed some light as to what might be going on here? I was told that the tip version is stable and working fine for plugins so hopefully it’s just some config thing I’m not getting right with the new all in one binary.

Andrew Simper


#2

Did you rename the bundle to .vst in order to have a VST version and to .component in order to have an AU version ?

The latest SVN version worked for me not so long ago.
At least they show up.

Still, there are some issue regarding carbon view in AU(especially in Live) and UI offset in Cubase.


#3

I rename the output plugin to .vst and .dll respectively and placed then in the appropriate folders but they don’t show up in any host.

Andrew Simper


#4

I just built everything from scratch again, double checking line by line through the plugin “How to use this framework.txt” line by line and still no luck getting Live to recognize the generated vst 2.4 only plugin using xcode 3.1 gcc 4 and compiling the demo plugin project with no alterations.

I would really appreciate some help on this one if anyone has a spare minute.

Andrew Simper


#5

:smiley: Gottit working.

All it needed on mac was a force rescan and the demo plugin appeared. There must have been a cached scan that didn’t display the plugin in the list for some reason. This is probably the same issue on win as well, but I’ll report back here when all is double checked and working.

Andrew Simper


#6

Well when I say gottit workin, it loaded in Live.

I am getting all sorts of crashes happening.

  1. Compile the combined vst and au of the demo project (on mac)
  2. Load Live 6
  3. press play
  4. load the au on a blank track, the user interface looks all funny, like some default au thing and not a juce inteface, move the volume fader and leave the gui visible
  5. load the vst on the same blank track and move the fader
  6. delete both and repeate at 4

One of the crashes is here on mac:

void MessageManager::doPlatformSpecificInitialisation()
{
if (juceAppDelegate == 0)
—>>> juceAppDelegate = [[JuceAppDelegate alloc] init];

If you don’t get a crash the first time doing this you soon will. Also the vst gui freezes up and sometimes you cannot move anything. Are the plugin crashing and the user interface not working known issues? If so I am a little worried that this is meant to be “stable code”.

Andrew Simper