Trouble with Mac VST


#1

I’ve got a plugin (announced just now, in this thread) which works as a Windows VST and as a Mac AU, but not as a Mac VST.

The Mac VST doesn’t appear in the plugin lists of Live and Tracktion. Miss Watson loads it, however, so I think it must be a problem with the plist, or something like that.

Has anybody else had trouble like this? I had a good deal of work getting the VST project to build at all, and had to tweak it – I may have broken something. (This thread was mildly interesting, but wasn’t resolved.)

The source code is available from this page, and also via Subversion at http://svn.berlios.de/svnroot/repos/bitcontrol/work. I could also put up a built version of the Mac VST somewhere, if anybody wants.

Thanks in advance!


#2

That’s odd - yes, I’d guess that it’s the plist or some other subtle build setting that’s stopping it. I’ve found that sometimes the bundle fails to actually show up correctly as a bundle, and just acts like a normal directory, but I’ve never worked out why this happens, and have always just worked around it by deleting the directory are doing a full rebuild.


#3

usually checking “force PkgInfo generation” and having a valid plist file is enough to ensure the folder is really seen as a bundle.


#4

Still no joy. It is definitely getting built as a package, and seems to have the right stuff in the plist, mostly – a few differences, but adjusting them to match similar working VSTs I have doesn’t do it. Permissions are alright too.

I looked at the exported symbols (nm -g). The wrapper currently defines only main_macho for the entry point, but VST 2.4 now wants this to be called VSTPluginMain. I added this, but it makes no difference whether either or both are used.

The only strange thing I noticed is in the output of nm -g. nm -g |grep main gives something like:

<adr> T _main_macho <adr> S main_macho.eh

along with some other symbols ( are addresses). Note that there’s no underscore in front of main_macho.eh. In the other VSTs I looked at, there’s an underscore in front of them both. The same applies to VSTPluginMain. I don’t know what the .eh symbol is, so I don’t know whether this makes any difference.


#5

Trying this on my plugins also shows that they’ve all got an underscore, so there’s probably something gone strange in your build settings… Best plan is to go through all your settings and compare them with the ones in the demo project.


#6

There was something gone strange in the build – somewhere. I don’t know whether it was the settings though. There were extras in there, so I backed them all out to match the demo. This still didn’t work, so I did a clean build (why didn’t I do that before??).

And hey presto – it shows up in Live, and it works, too!

Thanks very much for the help. You rock, as always!


#7

Yes - troubleshooting tactic #1 is always “do a clean build”… Even if it doesn’t work, it gives you a few minutes to think what might really be wrong.


#8