Vst problems with the new 1.50


#1

Hi,

since I switched to the version 1.50, I have several problems with the vst format :

  • on OS X, vst plugins won’t load - I guess it’s because I don’t yet use X Code 3.2 … (my snow loepard CD is on the way so I will soon have an answer)

  • on Windows, the compiled vst plugins load correctly with vst host, but won’t load under wavelab or cubase…(it userd to work with the 1.4)

any ideas?


#2

Can you try getting the tip from the GIT repository - I’m actively working on the plugin framework this week, and just fixed a few things, so any bug reports based on the 1.50 release version are probably out-of-date…


#3

Thanks ! I checked out the GIT repository, but unfortunately my vst plugins still freeze wavelab…


#4

Does the demo plugin have a problem?


#5

yes the demo plugin doesn’t work as well in vst win32.
I tried to build my plugin with the 1.46, and it worked.
I’m working with visual c++ express 2008 under windows XP sp3 (parallels)…


#6

Ok, thanks.


#7

oh, for god’s sake… I can’t even get the WaveLab demo to open in my Vista VM…


#8

D’oh !
they don’t work in cubase 5 as well…


#9

I can’t reproduce this - any chance you could grab it in the debugger and see where it’s stuck?


#10

unfortunately, the plugins are not accepted by the hosts as vst plugins, so impossible to load them…


#11

I thought you said it was freezing wavelab?

It it won’t load, you must just have a build setting wrong - the demo plugin definitely builds and runs just fine for me though (and presumably for almost everyone else, or it would have been mentioned by now!). I can’t really think what you might be doing wrong…


#12

Just checked our test plug-in (not the demo) plugin few things I’ve noticed with some hosts are:

1- wavelab 6 LE the UI is mucked up if it is moved at all. As soon as the window is moved certain sections of the UI are not redrawn properly. Also, in some instances the plug-in is not showing up and fails to be detected.

2-Logic 8 When I move the plugin window regions that have a repaint() or eg. repaint(0,0,100,100) shows a flashing white region, and overall the UI and interaction with components seems slow, hard to pinpoint exactly whats causing it.

3-Logic 9 Mac OS Leopard- Plugin gets scanned but not showing, could it be something with info.plist ?

4- Cubase 5 Vista32 sometimes again plugin gets scanned but not showing in host.


#13

Sorry, but are your points 1 and 2 on windows or mac?

It’d be really useful to use the demo to test with, because it rules out the chance that it’s something in your initialisation code that’s crashing and stopping the plugin getting loaded…


#14

Hi Jules,

1 - Wavelab 6 on windows XP 32 and 2- logic 8 on Mac OS 10.5, I will also try with the demo plugin


#15

Hi,

So I updated to snow leopard, then to Xcode 3.2. fine.

I tried to compile the audio plugin project, and everything is fine in AU and VST ; but if I change the plugin name (in the ‘edit active target’ window) The AU is ok, but the vst is not accepted anymore by any host…
I noticed that the difference between packages was the presence of the directory ‘AUPublic’ in the ‘good’ vst.

I didn’t figure out why this directory was copied if the plugin was called ‘jucedemoplugin’ and not if it was called ‘jucedemoplugin2’ (for instance)…


#16

AUPublic shouldn never be in the finished bundle (?)

If you’ve changed something and it doesn’t load, it’ll be because your plist no longer matches up correctly in some way.


#17

ok, so I should maybe have a closer look a this ‘${}’ problem


#18

Yes, just sanity-check the plist that it’s producing.


#19

Juce demo plugin still not working with cubase 5 , nuendo, samplitude PC XP. Can anyone else confirm this?


#20

Works just fine for me in Nuendo, (mac + pc)… (I don’t have Cubase 5, but AFAICT it uses the same engine)