VST loading on MAC


#1

Hi all,

I am using the audio plugin host from juce 1.45 on Mac OS10.4.11…
When i try to scan for the VST plugins that I have downloaded…nothing of them actually gets loaded up…I debugged and found that a carbon API
CFBundleLoadExecutable(line no. 443 of file VSTPluginInstance.cpp) is failing…This is the first time Im working on a Mac and it is getting really difficult…Could any one please help me with a solution…

Regards
Praveen


#2

Maybe try V1.46?


#3

Hi,

I tried 1.46 but am facing the same problem…

Regards
Praveen


#4

Interesting. Could you please tell me what plugins these are? I would be interested in fixing this as I also use 1.46 for my projects.
On my system, I can load VST’s, but ofcourse I did not try all existing VST’s :slight_smile:


#5

Hey,

Finally I got a plugin to work…I think the plugins i tried to load earlier were not compatible in some way…
I just downloaded a vst plugin(“Excitifier”) which worked…
Location:http://www.greenoak.com/vst.html

For your info one plugin which did not work earlier was “Amplitude Imposer” which i had downloaded from the location :
http://www.freesoundeditor.com/VSTFiltereng.htm
Also few more plugins from this location did not work…
Not quite sure of the reason…
May be these plugins are not compatible with OS10.4…

Thanks for all the help…

Regards
Praveen