Problem loading plugin in "audio plugin host"


#1

Hi all,

I am trying to follow the tutorail at http://www.juce.com/learn/tutorials-code-examples/create-basic-audio-midi-plugin-part-1-setting-up. I have successfully passed all the steps of all the parts. The vst file has also been created and exists in ~/Library/Audio/Plug-Ins/VST. Now , when I try to scan for vst in audio plugin host I get below error code:

"

Scan complete

Note that the following file appeared to be plugin files, but failed to load correctly:

FirstAudioPlugin.vst

"

I also tried VSTlord to open the vst file, it says "Could not load the bundle". Is there anything missing from the tutorial page? because I followed the exact same steps.

Thank you for your helps.


#2

I do not know what you have as a source code (would be nice to see it) but do you have a function like this:

 

AudioProcessor* JUCE_CALLTYPE createPluginFilter()
{
  return new <YourPluginProcessor>();
}

 

Mind the <YourPluginProcessor> Placeholder which should be replaced by your Processor Class. This Function should be placed inside your Processor.cpp File (but it is also possible to put it somewhere else). This is something like the starting point for the host to get an instance of your VST Plugin.


#3

Hey all, 
Same problem here. 

Followed the steps of the tutorial: http://www.juce.com/doc/tutorial_create_projucer_basic_plugin
Everytihing worked and the plugin was built successfully. 

Followed the Setup Plugin Debugging instructions and created the Juce Plugin Host correctly. 
However, when following the steps and trying to add the plugin to the Available Plugin List I get the same error: 

"Scan complete
Note that the following file appeared to be plugin files, but failed to load correctly:"

I have tried this a couple of times, down to the smallest detail, and still get the same issue. 

I'm new to this so any very simplified help would be much appreciated ;). 

Cheers. 


#4

Maybe an issue with architecture? Check to make sure your Plugin & Plugin Host architectures match.


#5

I had the same issue.  If you are using Xcode, in your project settings, see if the "OSX Deployment Target" version is higher than your system. 

When I upgraded from Xcode 6 to Xcode 7, it broke the plugin I was working on.  That settings defaulted to 10.11 even though my Mac was running 10.10.  Setting it back to 10.10 did the trick for me.


#6

Same issue here, but works after configure OS X Deployment Target to 10.10.