Plug-in host scanning plugins bug

I am trying to get juce to work for making an audio plugin. Now I ran into this bug while trying to scan for vst’s to use with the plugin-host. I am following this (JUCE: Tutorial: Create a basic Audio/MIDI plugin, Part 1: Setting up) tutorial, one of the screenshots just shows which part I am stuck at.
All help is appreciated, I have no idea what to do now!
3 screenshots attatched :slight_smile:
“An error occurred: Sorry, new users can only put one embedded media item in a post.”
great forum I guess. makes it so much easier for me to describe my problem.
anyways, the plugin host just keeps scanning for vsts and is stuck at 0%. the one screenshot shows the vs window that pops up when i do that scan.

hey there, I was playing with the plugin scanning not long ago, It may be fresh enough to help you. Can you show the code you used to get there?

1 Like

i didnt use any code yet! the tutorial says its just supposed to scan some plugins for now so i can use the plugin host for testing purposes. i am just setting juce up right now, havent written a line of code for now. all the code is “stock”

does it behave the same way once you build it in release? I mean, does it crash?

1 Like

That is hitting an assert, because it’s not coming from the Message Thread. Set theAudioPluginHost, in the Plugins scanning window, to use “Out-of-process” scanning at the bottom right.


thank you! that fixed it:)

i actually dont know what build in release means, but it works now, thanks for ur help!

You can build either a debug version or a release version. 2 frames left from the button “continue” on your screenshot, you can set the type of build you want.

1 Like