Issue building demo audio plugin in xcode


#1

Hi ,
I dont understand why i have this issues compiling the demo audio plugin under xcode in the juce vst wrapper:

/juce/extras/audio plugins/demo/Builds/MacOSX/…/…/…/…/…/…/juce/extras/audio plugins/wrapper/VST/juce_VST_Wrapper.cpp:860:0 /juce/extras/audio plugins/demo/Builds/MacOSX/…/…/…/…/…/…/juce/extras/audio plugins/wrapper/VST/juce_VST_Wrapper.cpp:860: error: no matching function for call to ‘isPositiveAndBelow(VstInt32&, int)’

If someone can help me … :slight_smile:


#2

Do you have multiple versions of juce installed? Sounds like a recent wrapper file might be including an older juce header.


#3

Thanks ,
I’ll try this and I ll keep you in touch …


#4

I got my new Mac and trying the Juce 1.52. I worked with 1.50 quite a bit on Windows before .
I have similar problem as above…I cannot get the plugin demo to work in the XCode.
I downloaded Juce 1.52, I made copies and renamed the folder to “Juce 152”.
I placed “public.sdk” in …/audio plugins/wrapper/vst folder.
I run JuceDemoPlugin.xcodeproj . Right away, juce_VST_wrapper.cpp, juce_VST_Wrapper_mm and also juce_AU_Resounrces.r and Juce_AU_Wrapper.mm were printed red.
It turned out that those files were hard-wired to “Juce” folder and after renaming the folder they no longer could not be found.
OK, I renamed the “Juce 152” back to “Juce”. I restarted the project and those files loaded fine this time. Then I tried to buils it. I got 127 errors. Fist few were:

#include <public.sdk/source/vst2.x/audioeffectx.h> - Err: No such file or directory…
#include <public.sdk/source/vst2.x/aeffeditor.h> - Err: No such file or directory…
#include <public.sdk/source/vst2.x/audioeffectx.cpp> - Err: No such file or directory…
#include <public.sdk/source/vst2.x/audioeffect.cpp> - Err: No such file or directory…

The “public.sdk” folder and all h/cpp files are definitely there. Why they are not found?

I tried many tricks to no avail. No matter what, the XCode could not see those includes (<>).
Then I tried with quotations just like this:

#include “public.sdk/source/vst2.x/audioeffectx.h”
#include “public.sdk/source/vst2.x/aeffeditor.h”
#include “public.sdk/source/vst2.x/audioeffectx.cpp”
#include “public.sdk/source/vst2.x/audioeffect.cpp”

After that, “No such file or directory…” errors have disappeared but I got some other 250 errors. What gives?

The project builds fine if ‘#define JucePlugin_Build_VST’ is set to 0 but if course I want to build the VST plugin.

Please someone help…


#5

Having the same problem myself.  Can't get the demo app to build on Xcode and have wasted more time on it than I'd like to admit :(

 


#6

Also, for some reason, I don't have the VST Folder setting like I do on other JUCE projects I have.

 

 

I went ahead and edited the XML file directly to change the setting to the correct location, but that didn't seem to change anything about this error.

 

Thanks if anyone has input!


#7

The thread you're reading is massively out-of-date. And it looks like you're not using the latest version of introjucer? Best to get the latest version from GIT.

If the VST path is missing, it's probably because you've not set the overall project type to "Audio Plugin" and ticked the VST option. Those settings are on the project's main config page.