Issues Loading Audio Units


#1

We’ve been having some issues with loading our Audio Unit plugins on our development machine (iMac running macOS 10.13.3).

Our plugins are currently being built as Universal Binary (32/64 bit) Audio Units and targeting OSX 10.6+.

The initial builds of the plugin load up and run fine in 64bit Logic X, Reaper, etc… however sometimes I will clean the project or delete the AU and rebuild and it starts having issues being seen by auval.

When this happens the AU plugin will only show up as 32bit when validating (auval -32 ...) and still succeeds, auval just never actually finds the plugin in 64bit. I’ve verified with file that the output binary is still a Universal Binary supporting 32/64 bit.

I’ve tried lots of combinations of clearing the Audio Units cache, rescanning in Logic, cleaning & rebuilding the project, restarting the machine, etc. and still no luck with getting the Audio Unit to be found as a 64bit AU plugin anymore even though it was found after the initial build.

Has anyone else encountered this issue?


#2

Maybe you are experiencing this:

Good luck!


#3

Thanks @daniel, the renaming workaround seems to work here! Hoping Apple digs into this problem soon