Logic Pro - Rescan plugin folder (how to avoid scanning all plugins)

I’am experimenting with JUCE plugins setting “Plugin AU Main Type”.
But I can’t find how and when Apple rescan my /Users/MyNane/Library/Audio/Plug-Ins/Components/ - where xCode places my built plugins.

(please notice it’s my User library, not MacintoshHD)

Now and then in the plugin manager I can’t even see my plugin.
How to ensure every time I rebuild my plugin in xCode, Logic also rescan my User library audio units folder? And of course I have planty of other plugins on my main MacintoshHD library, so I want to avoid rescaning it everytime, due to lack of time.

Logic X will only scan the system folder /Library/Audio/Plug-Ins/Components in my experience. You’ll have to move your plugins into there for Logic to find them

What I do is allow write access for myself to that folder:

(CMD + I on the folder in Finder, change your user to “Read & Write”)

Then have JUCE output my plugins there directly in my Projucer settings:

The “AU Binary Location” setting will have to be set for both Debug and Release

1 Like

Thanks, But I think it’s not the answer. As I told my plugin sometimes normally works from my User library, but sometimes not. By the way, all developed by myself plugins are in User library audiounits, and they all works fine. The problem is when I experimenting with JUCE plugins setting “Plugin AU Main Type”.

And also asked how to rescan my plugins in Logic pro only my user library.

I know I can remove com.apple.audiounits.cache , but then Logic scan all my about 500 plugins. It’s annoying

Unfortunately as far as I can tell the only thing Logic provides is an option to rescan a selection of AUs that may have failed.

They don’t seem to offer any method to rescan without clearing com.apple.audiounits.cache, and they don’t let you specify a specific directory to rescan either.

Also what version of OSX are you on? There is an issue with AudioUnits on OSX High Sierra if you’re running that version:

I’m on High Sierra and most of the time I have to do that “renaming” trick that’s explained in that thread

OK, thanks

But now I see: I make my plugin type to be as kAudioUnitType_Generator. And Logic see it, that’s great. But then I changed my plugin to be kAudioUnitType_Effect. I removed all builds, and myPlugin.component file, and rebuilt everything.

But Logic still recognize it as a Generator. How to update it without scanning all my 500 plugins?

I believe if you change the type of an AudioUnit, OSX won’t find it unless you clear the AudioUnits cache or put the old plugin (with the original type) back.

We ran into some similar issues when we changed the channel count of an AU plugin of ours, we had to clear the cache for Logic to pick it up.

OK, but do I need to clear whole cache (delete file)? Can’t I somehow clear only part that concern to my plugin?

I just opened com.apple.audiounits.cache with TextWrangler. There is totally crazy staff. But maybe someone know how to edit it for desired effect?

Yeah I don’t think anyone here is going to have information on that, it would require reverse engineering the file. I checked it out in a hex editor and there’s no immediate, easy way to tell what’s going on in the file.

Sometimes I have luck with removing the plugin, running Logic or auval, then building the new version of the plugin. But even then I’ll have to clear out my cache occasionally depending on what I’m working on.

Now I start crying.
I just removed cache, and run Logic, it scanned all plugins (about 15 minutes)
Please help

Are you sure you don’t have a second copy of the plugin lying around or something? I would make sure you’ve deleted all copies of your plugin, then resave your Projucer project, and rebuild from Xcode.

The easier way for checking your plugin would probably be to use auval instead of running Logic every time. From the command line:

auval -a

…will show you all of the AudioUnits that OSX can find on your system, including their types. I believe the generator type is “augn”, so that would be the first word on a line for a generator.

If you’re plugin is a general “effect” then auval would print “aufx” as the type on the line where the plugin would shows up (if it scans).

Oh man still crying :slight_smile:
after I run auval -a it returns me all plugins, and there isn’t even one of my plugin. I coded with JUCE about 10 plugins, and almost all of them normally work in Logic. But they are not listed after auval -a. I copied all return of auval -a and pasted it to TextWrangler, and searched keywords. Nothing found.

What operating system are you on? I mentioned above there’s an issue when adding new AudioUnits on OSX High Sierra

OK, so it clear now (sorry I forgot what you mentioned about that)
I run High Sierra. So there is no solution for me? Do I need to create whole new project in Projucer, with new name of my plugin?

No, read the thread I posted.

The solution is to rename the plugin you’re trying to add. For example if I build a plugin “foobar.component”, renaming it to “foobarz.component” then back to “foobar.component” usually gets it to load.

If the renaming doesn’t work then you’ll have to restart every time you change the attributes of your AudioUnit such as type (generator, effect, etc.), channel count, etc. Changing the code is usually fine but higher level changes to your plugin’s configuration may cause problems.

1 Like

Great thanks, it helped

1 Like