JIT process stopped responding

Hey, it seems much more stable with the 10.10 SDK after a quick test. I’ll have a a more thorough play around with it as soon as I can.

I’m having the same problem running XCode 8 on 10.11.5. Going to add the 10.10 SDK and see how it goes. I’m not sure if this is still an ongoing issue but Stefan’s solution is the one thing I can find when Googling.

There is still no solution to this? I have Visual Studio 2015 Community and I’m getting the exact error “JIT process stopped responding!” … From the other PC I’m running it without any issues. There I have Visual Studio 2017 Community. Doubt VS version causes this issue tho.

Can you try the latest version? See this post

I’ve seen that and I’ve tried it already. Did the reinstall several times and tried the deleting dll file. No results unfortunately.

Did you try selecting “Clean All” from the Build menu?

I’ve got the same issue here on Windows 10 and JUCE v5.1.1 … I’ve tried “Clean All” but it didn’t help. Any ideas?

What version of Visual Studio do you have installed?

VS Community 2017

Did you customise the installation at all? The live-build engine requires that you have a version of the Windows 10 SDK installed and also Windows Kits (either v8.1 or v10) - can you check that you have these? They should be located at C:\Program Files (x86)\Windows Kits

I didn’t know, sorry. However, I just installed the SDK, I see both 8.1 and 10 in the folder mentioned, but I still get the same error…

OK. Just to be sure that you’re definitely using the latest version of the live-build engine can you download JUCE from the website here and open the Projucer.exe that’s located in the main directory. Then try opening one of the example projects such as HelloWorld from the examples subfolder and enable the live-build engine.

alright, it works with the example projects! I still get the same error though when trying to run my plugin I’m currently developing… What does that error even tell me? I don’t know where to start looking in my code now…

Yeah looks like it’s an issue when live-building plugins, I’ll take a look at it.

EDIT: seems fine building the demo plugin, not sure what the issue with yours could be…

ok, thanks for looking into it! I’ll probably rebuild my project and see if it works then…

Hello, I’m sry for being inactive. I’m using JUCE for my bachelor thesis so now I’m back here trying to make it work. The current problem I got is this (take a look at error list): Capture

Any guesses?

EDIT: I deleted my Visual Studio Community 2015 and installed 2017 Community version and now it works like a charm. I’ve no idea what was the reason. Thanks for all the comments and help, cheers!

Best regards,
Bruno

1 Like

@gbevin did you ever solve your issue?

I’m having the same problem as you, the “JIT process stopped responding” error, on macos 10.14.5, Juce 5.4.5 ( downloaded binary, but the same problem arises if I use a compiled Projucer), Xcode 11.1. I tried doing clean all, adding all macos SDK versions in the XCode bundle… But I still can’t live build. Getting this error in the projucer log:

**********************************************************
Projucer 5.4.5  ---  Build date: Oct 16 2019
Log started: 10 Jan 2020 4:52:30pm

Mac OSX 10.14.5
CPU: 2600MHz  Cores: 8  16384MB
Loading project: /Users/bloit/Library/Caches/Projucer/PIPs/HelloWorldDemo/HelloWorldDemo.jucer
*** Child process crashed: 

Oh and I checked, the dylib for the compilation engine is downloaded.

All of you mac users are able to use the live build engine?
Any help would be appreciated!

I have not had that problem, but despite clearing everything I could find, recompiling the Projucer, and hoping a bunch, I still have the problem shown in this post. I am using the dev branch (up to date) on OS X 10.15.12. Working with Xcode and VS Code works as expected.

I tried reverting from XCode 11.1 to XCode 10.3 and it works again for me. It’s a wild guess but maybe this is due to the JUCECompileEngine.dylib file not being compiled with a matching XCode version. @ed95 does that sound plausible? Can we compile this library from the JUCE sources?

I’m using Xcode 11.1 on macOS 10.14.6 Mojave & I can’t get the live build engine to do anything at all. I’ve tried creating simple projects and loaded some of the JUCE GUI examples as well. I just don’t get any activity at all when trying to build.

All of the Components I want to test have default constructors.

I’d like to try using it to design simple GUI components in a separate “playground” project and then copy over that code to my actual projects.

1 Like