JUCE 5 and Projucer system requirements


#1

Hi, new here. I’ve tried searching for the min requirements to use Juce and Projucer on a Mac, but have not been able to find them. Can someone point me to the relevant information?

Thanks,

  • Stephen

#2

I think as long as you’ve got Xcode 8 or 9 then whatever system you’re running should be fine.


#3

There’s also the ability to run Projucer itself. For example, OSX 10.6.8 cannot run Projucer 5.3.2 I just found out.

So now I’m trying to find out what the cheapest Mac I can buy which will let me run Projucer 5.3.2. The downloads and release info pages don’t mention the minimum required version of OSX.


#4

There was another breaking change from MacBook4,2 to MacBook5,2 in 2008-2009. The MacBooks before 5 are limited to OSX Lion (10.7). I don’t know the reasons, maybe GateKeeper had an impact, so that they felt they had to drop backward compatibility.
Personally I would avoid anything before MacBook5 from 2009. The later ones all can run to the latest OSX, so they should be fine.
I haven’t read anything about 10.14 Moyave though, but I think they would have published, if the current MacBooks would no longer support that.


#5

Oh okay, thanks. (I’m still new to the mac world.)