Crash: Mavericks 10.9.5


#1

Hi,

I downloaded the last version of Juce (4.0.2) and I'm trying to open it on Mavericks 10.9.5, but it always crash before open the main window.
I have installed the last compatible version of Xcode (6.2) with Mavericks.

In the path: /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs
I have 2 SDK's: 10.9 AND 10.10

Here I attached a PDF print screen of my error. Please, look it.

I have tryied use Juce on Yosemite 10.10.5...it open the main window...I got a lot of errors...and Juce can't compile anything.
In this case, my SDK is 10.11.

Help me, please!

Thanks!
Nyck


#2

The Projucer is not supported on 10.9 (yet) :)


#3


Which Mac platform is Juce fully supported?
I have tried OSX 10.9.5 and OSX 10.10.5.
In both cases I had problem.
 


#4

Strange! I am actively developing with the projucer on OS X 10.10.5; perhaps something went wrong with installation of either projucer or Xcode?

 

Cheers,
B

 


#5

10.10 or later definitely works - we use that version ourselves.


#6


I do not understand what may be wrong in my system.

I have a Macbook Pro, Core i7, 2.66GHz, 8GB RAM.


In this notebook I have two separate partitions, which were recently fully formatted, ie, the operating system is 100% brand new and perfect:

1- OSX 10.9.5 with XCode 6.2 (downloaded from Apple Developer site)
2- 10.10.5 OSX with XCode 7.1.1 (downloaded from App Store)

After you install XCode on both systems, I downloaded the VST SDK 3.6.5 from the Steinberg website.
Then I downloaded the last stable release from Juce site (4.0.2) in both systems.

My setup sequence in both systems is the same:
1- Open ProJucer -> New Project
2- Audio Plugin (MacOSX - XCode)
3- Config Tab: just BUILD BUILD VST and VST 3 enable 

4- Mark Plugin is a Synth Plugin MIDI input, MIDI output Plugin

5- In Config Tab: XCode (Mac OSX): I set it full path of the VST SDK 3 Folder: /Applications/VST3_SDK/
6- In Release and Debug: I September OSX 10:10 in OSX SDK Base Version, Deployment Target
7- OSX architecture: 64-bit Intel


Then I click menu Build -> Clean All

Using OSX 10.9.5 ProJucer can not open the main window and gives me the attachment error in this question above.
Using OSX 10.10.5, the ProJucer opens normally, do the configuration as stated above and then I see:

That some AudioHardwareService is deprecated
And I saw one error: "enumerator value evaluates to -2147483648, Which can not be narrowed to type uint32_t (aka unsingned int)"

Finally, the ProJucer can not create the file after the Build process.

What should I do?

Here I attached a PDF with my error screen again.


#7

Hi,

I tested Juce 4.0.2 in another computer.
In this case: iMac core i7 3.5 Ghz, 16Gb RAM.

Running OSX 10.10.5

I got the same errors!

I downloaded the FREE version of Juce.

Maybe this error is inside only in the FREE version of Juce...


#8

There's nothing different in the free version, we only have one codebase.

Pull the latest version from GIT - we fixed things recently like the enum error.


#9

Ok,

In Terminal I put:
git clone https://github.com/julianstorer/JUCE.git

But inside this folder (JUCE) I not found the MakeFile to build ProJucer app.

How can I get ProJucer updated?

Thanks!


#10

The projucer is closed-source, but it hasn't changed, you need a new version of it. It's the library you should update from GIT


#11

Hi, thanks...

I'm newer in GIT.

Please, could you write here the command line to I get the updated ProJucer?
Is just copy and paste this line on mac Terminal?

Thanks again!


#12

Like I said, you don't need a new version of the projucer.

Just get the latest version of the JUCE library itself. Use github to do that: https://github.com/julianstorer/JUCE


#13

Are there any news on Projucer on 10.9.5? It would be great, if it will work on Mavericks ;)

 

Cheers,
Thomas


#14

We're not planning on ever making it run on earlier versions than 10.10. Getting our LLVM system to be compatible with 10.9 is difficult and it's just not worth the hassle for us to work around it, as most developers are on the latest version of OSX.