Juce pluginhost does not detect any plugins after 5.4.3 upgrade

Hi,

2 weird things after (kinda late) upgrade from Juce 5.4.2 to 5.4.3 and Visual Studio 2017 -> 2019

  • Projucer always opens Visual Studio 2017 - even when I set the exporter to 2019. Any reason why?
  • I rebuilt the audioplugin host - compiles with no warnings, but refuses to scan plugins. When I hit scan it just does not detect anything… Can anyone image why that would be?

FWIW: I rebuilt the plugins I’ve developed so far. Those build fine, and open in other hosts. BTW the Juce plugin host does not detect any plugins, not even e.g. Kontakt or Keyscape. I did set the plugin paths of course :slight_smile: .

Any clues would be appreciated!

Tom

Projucer uses the OS to launch visual studio based on file extensions, just like double clicking a file does. You need to change the *.sln file association, in the OS, to launch Visual Studio 2019.

I haven’t tried 2019 yet, but I would have thought it would appear as a choice in the ‘exporters’ list? Which you’d have to add.

@cpr : thx that does the trick.

Anyone any clues why the Juce plugin host might refuse to detect any plugins?

One of the reasons I went with Juce is the compatabilty with many hosts.
You’re not saying which hosts have a problem.
Is the plug in the correct directory? A silly question I suppose, but it’s easily done. Also, some hosts may require a rescan to find your plugin.

The poster said the problem is with the JUCE plugin host. (Which is in the JUCE extras directory.) It’s kind of amusing if the JUCE plugin host can’t load plugins built with JUCE itself…(But I suspect it’s probably some issue with 32 bit versus 64 bit builds or something…)

edit : For what it’s worth, the JUCE plugin host (AKA AudioPluginHost) seems to build and work fine here when built with Visual Studio 2017 and the latest JUCE develop branch. Both VST2 and VST3 plugins load. Maybe Visual Studio 2019 has changed something in that regard…?

@DaveH : like @Xenakios said, I’m talking about the Juce plugin host.

And it’s not just Juce plugins - it just doesn’t detect any plugin. I double checked that I had not by chance compiled a 32 bit version trying to load 64 bit plugins but that’s not the case either…

Weird …

Bump? Am I really the only one with this issue? I tried recompiling on a different machine - still same behavior - no VSTs seem to get detected at all! I’ve reverted to debugging in a different host for now, but not very practical… Anyone any clue what might cause the Juce Pluginhost to refuse to detect external plugins? I’m kind of out of ideas here …

Can you check that the JUCE_PLUGINHOST_VST and JUCE_PLUGINHOST_VST3 flags are enabled in the juce_audio_processors module?

1 Like

That was it! Tx @masshacker ! The line to #define JUCE_PLUGINHOST_VST was commented out in the code. No idea why that would be the case?

Probably because VST is no longer included by default…

Also note, in AppConfig, that line is autogenerated. You can switch those settings from Projucer on the modules tab:

1 Like

Got it, good to know! Tx for your help!