Ld: table of contents for archive: ../../../bin/libjucedebug


#1

Its all in the title:
ld: table of contents for archive: …/…/…/bin/libjucedebug.a is out of date; rerun ranlib(1) (can’t load from it)

The lib compiles fine, but when using any of the demo projects I get this single error. Anything?


#2

That rings a bell but I can’t remember exactly what caused it. I think it was something trivial though, like just needing to do a clean rebuild, or not having built both projects for the same architecture.


#3

you wouldn’t happen to have an exact solution or a precompiled library for a mac?


#4

No. Did you try deleting the .a file and rebuilding it? It’ll just be xcode not building something properly.


#5

Of course, still can’t get it working. I’ve tried every little trick I know. Then I tried it right under ld and it still dies. Me thinks your code isn’t working properly.


#6

Well the code works properly for me and the hundreds of other mac users!

I’ve seen that bug before, but it was a long time ago, and I’m pretty sure it was being caused by some kind of build tool messing up. Are you using the latest XCode?

And are you sure the the other projects aren’t trying to link to some other old juce.a file lurking somewhere on your drive?


#7

Aaarghhh…

I’ve just rebuild my MacBook (now a dual-boot with Win XP using BootCamp - woo hoo!)
… and have rebuilt juce…

… and am now getting the same error when I rebuild my apps or the Jucer. :frowning:

How pants is that?

If you run this from a terminal window:

man ranlib

and look at the bottom, you see this…

Has anybody got any bright ideas?

The file in question is juce/bin/libjuce.a … FWIW!

Help. :frowning:

Pete


#8

Aha!

Turns out that this is an XCode bug.

The XCode that came with my Mac installed version 2.2.1

The latest version (2.4.1) fixes this. You can get it from the Apple website. I’m just about to install it…

The reason that this was all working for me earlier today… is because that was on a previous, upgraded incarnation of my MacBook … on which I’d installed the latest version of XCode … (my re-install of Mac OS X regressed this…) :slight_smile:

Hoping this helps,

Pete


#9